Completed - Resolved

Cannot connect to games via WAN

Captaincandle 6 years ago updated by Lee "Noontide" Moon (Designer & Community Manager) 5 years ago 16

I am using Steam version of the game. 

Game build:1.6.66f3

OS: Windows 10 professional (64bit)

RAM: 16 gb

CPU: i7-7700k @4.2ghz

GPU: GTX 1080

When attempting to host game, error displays "The ports 27015 and 27016 are closed" I have covered the port forwarding sections of the forum. I have my machine in the DMZ so all ports should be forwarded. Just to cover all bases, these ports have also been manually forwarded. I have tested this on my mates PC and he has followed the same instructions and the same issue occurs. When direct connecting error reports: Connection Error. Connecting to the server failed!

When attempting to connect via LAN the game works fine. 

Unsure how to proceed as the ports should all be forwarded however the game detects them as closed. In have other example games that work fine such as Killing Floor 2, which needed the machine to be in the DMZ/port forwarded to host online games. This has been tested and is working.

Please assist. Happy to provide further info. the log examples on your main bug-tracker page didn't seem pertinent as there is no crash or report being generated. 

Game Version:
Steam Public

Output log file Attached just to cover all bases. this error occurred in the last play session.

Pending Customer

Can you please try to disable all other network adapters in Windows and then try. Things like Hamachi can cause issues.

Please also try without firewalls and ensure that you are using the Public IP address shown in the lobby. 

If the above doesnt work then remove the device from the DMZ and disable UpNp. Then remove and re-add the port forwards.

Hi Cian, 

Thanks for getting back so quick, genuinely impressed. I have tried all the above options and the game will not detect the ports as open. In the final step, UPnP is disabled and no DMZ, just the port triggering setup (external port is the same right?), with no success. I also disable my second network adapter (I have two ports, no custom adapters) with same result. Finally, disabling all firewalls (I don't run one but disabled my anti-virus) had no success either. This one has me stumped.

To clarify, my router has no firewall options turned on either during this testing. It's just a basic router firewall (blacklist/whitelist) anyway and isn't setup. Just wanted to be thorough

Hi Captaincandle,

Can you send through a screenshot of the configuration for your port forwarding on the router. Honestly I'm not sure what could be causing this either though ULink can sometimes throw a wobbly due to unusual cases, unfortunately without knowing much about the network we're dealing with it's also very difficult to advise.

Just to clarify as well when you're attempting to connect via WAN is this the internet as your medium or some form of privately owned and operated WAN (i.e. between two LANs owned by a single company using wireless?).

When you're receiving the Port Forwarding error message on hosting a game have you actually tried hosting the game and have your friend connect? It is possible that the PF check is not communicating properly with your PC for some reason.



Hi Lee,

Absolutely: Port setup.png

I'm using the Internet as the medium, no private WAN setup.

The setup is PC -> Dumb switch -> Router -> Internet. Nothing custom in that setup, the switch just routes traffic, router is only setup to connect to the internet. no other setting other than static IP to my machine (which is usually in the DMZ, but turned that off form our testing). 

I have tried hosting and have my friend join to no avail. That was the original test, and what I have used in all testing. I continue to get the error message notice in the host screen stating the ports aren't forwarded.

Please hit me up for any info you need.

Hi Captaincandle,

I think it's likely that the issue here is the setup has been configured as port triggering as opposed to a virtual server. The problem with Port Triggering is that it requires a client (your PC) to make an outgoing connection on those ports before the router forwards those ports to the client. This means that if your PC does not make an outgoing connection on those ports the router never forwards the ports to your PC. It also means that if another client makes an outgoing connection on those ports they get the forwarding instead.

I'm not an expert on the intricacies of how ULink is working, or how we communicate with the Steam master server but as I understand it there shouldn't be any outgoing traffic on those ports, as a result the forwarding is never established.

Instead you should setup your port forwarding as a virtual server pointing directly to the local IP of the PC that you want to act as the host. This should ensure that the traffic always goes to that PC rather than waiting for the PC to establish an outgoing connection on that port.

Give that a go and let me know how you get on. :)



Hi Lee,

Just set it up as such, is this correct? Never setup port forwarding as a virtual server before. It still asks for an external port.

Port setup 2.png

This looks correct. Virtual Servers is essentially what is conventionally known as port forwarding. It'll ask for an external port as it needs to know what to listen to, any traffic that reaches the router with that port ID will automatically be forwarded to the Interal port on the client IP Address you set. Provided there's a service listening on that port :)

So basically. IP Packet reaches router > router reads the port ID > If port ID is in the forwarding table (virtual servers) > forward to chosen internal IP with the chosen internal port. 

So when your friend tries to connect now as long as something is listening on that port (in this case WFTO) data should come through from your router to your PC. Whenever you're asked to port forward by an application (Usually for hosting game servers these days) you'd usually use this setup.

Fantastic Lee, that is an awesome explanation. Much better idea than I had before. You can tell my network game is really limited.

It is 01:45 here in Australia so I will need to wait until at least tomorrow night to try again. I will update you as soon as I know.

Have an awesome day today.


Great, I'll look forward to hearing good news! :)

No worries on your Network game, to be honest it's a pretty arcane subject very similar to black magic. Even with a BSc in Computer Networking it's still requires a sacrificial ritual involving a goat before it works as anticipated. :)

Funnily enough our Australian producer is also called Scott no relation I presume. ;)



Hahahahaha! I think pretty much all ICT is black magic. I'm a desktop guy by trade so I get some exposure but not much.

No, but that is an interesting coincidence. maybe I'm running a test on customer service?? If it helps you're ace'ing it =).

Hi Lee,

We attempted the fix above but still no joy. I've tried several combinations in tandem with the manual port forwarding and nothing. I unfortunately only have one person to attempt this with, but they have used two separate network setups to try with. This weekend we will try port forwarding on his end (he is in the DMZ but can't change the setup he is currently using) in the event this is the issue.

Apologies about the late reply.


Hi Scott,

I'm sorry to hear that it seems our sacrifice to the dark gods of networking has failed and the port remains stubbornly closed. At this point I'm somewhat at a loss, there shouldn't be any reason from our perspective why that isn't working, my only thought comes to Windows Firewall right now. Although you don't have a third-party firewall it is possible that for some reason WFTO is not allowed through your Windows Firewall and if that is running it could be the cause of the problem.

Could you make sure that both the WFTO.exe (Appearing as War for the Overworld in the list) and WFTOGame.exe are added as programs which are allowed to pass data through Windows Firewall? You could also check the advanced settings to see the actual Inbound rules for WFTOGame.exe and WFTO.exe as well if we want to be thorough.

You'll see multiple instances of WFTOGame and War for the Overworld depending on a number of factors (install instances in my case, but also for each protocol used).

After this I'm starting to run out of ideas, I have no reason to doubt that the setup is fine but one option would be doing a quick Teamviewer session at some point so I can check the configuration of things directly (Timezones would make this difficult of course) or perhaps it would be better to look into using something like Hamachi to create a tunnel as a workaround, though I'm not sure how well that works in the context of WFTO.

Let me know how you get on, also just so you know we're currently on leave at the moment for Christmas so my responses will be more delayed as and when I find time to offer further support. I apologise for this inconvenience.

Best of luck,


Hi Lee,

Managed to get it working. I'm still face-palming! So, despite the fact that Windows firewall is turned off, I took your advice and added the entries above. Would you believe it worked?! This tells me not all of the firewall shuts down despite the options, so that is a plus.

I want to extend a big thank you to yourself and the company as a whole. You have been extremely patient with my issue, despite the simple fix (Seriously...) and I have not, in many many years, experienced that kind of service from a games company. 

You will continue to have my social and financial support. I'm not rich, but hey, every person counts right?


Completed - Resolved

Hi Scott,

That's great news I'm pleased that my last insight proved to be fruitful and continues to demonstrate the blackbox that is networking issues. Yet another peculiar behaviour from MS with the firewall working despite being disabled. Remember as a power user you need to be protected from yourself!

I'm pleased to hear that you find our service to be amongst the best, it's a treasured part of our philosophy as a company and despite our small size I endeavour to offer the best we can.

Thanks and enjoy the game!