Map Editor Can't delete Artifacts

  • updated
  • Completed - Resolved

So on the Map Editor. I noticed the delete object is done by left clicking on the object to basically pick it up. Then right click to cancel action. Which work great most of the time. But I found I can't delete Artifacts for some reason.

A few other objects are kinda annoying to delete too. Bridges, Overworld gateways etc need another object placed on it to delete them. It works for now though. Maybe a delete object command is needed?

Game Version:
Steam Public
Jan - Eric Merzel
  • Under Review

ill look at the first issue.

The second one is a little trickier. All the rooms have to be overridden with other tiles to "delete" them.

Its just how our system works. if you could delete it there would be nothing below it as earth is just as much terrain as lets say a claimed tile or Lava. I actually gave this feedback while the editor was still in development, maybe it will be possible to just revert everything back to earth if you delete it. but then again im unsure if that would help you.


Also there is a "delete" button, it's where the sell button (for selling rooms in normal play) usually is.

Hope that helps.


Its true that artifacts, once placed, can't be picked up (and then deleted with right click)

they can only be deleted by using the delete button (while all other defences/constructs/units can be dismissed by picking up and right clicking)

I honestly don't know don't know if thats really a bug or merely a feature, so i owuld leave it to our sevs to decide if that needs a fix or not.

Stefan Furcht

It might be that it was just forgotten to add.
I would still suggest to raise a ticket even if minor it would be more consistent if it can be deleted(copy spelled) by click.

Jan - Eric Merzel
  • Completed - Resolved

i just tried it, and it worked fine?

did you just fix it for yourself V0id?