0
Cannot Replicate

Home Realm Black

Lee G 2 years ago updated by Cian Noonan (Graphics Plumber) 2 years ago 10

I just did mission 8, "Desecration," and went to the Home Realm (going for the "Stay a While and Listen" achievement) and the play area is covered in black.  Possession works fine but when I leave possession, it goes back to black.  I suspect my view port is way outside of the playable area and locked in  that position.  Here's the save that loaded (I think): home_realm_black.zip


This is what I'm seeing:

Game Version:
Steam Public
Platform:
Windows
Under Review

Hi Lee,


Ah that's no good! Can you try clicking anywhere on the minimap to zoom the camera to that location?

Interestingly the minimap does not show the painting of camera frustrum which means the camara must have ended up in a weird place.

I'm 80% sure the camera was due north outside of the play area.  I did click on the minimap, tried clicking on the dungeon heart icon, tried panning with keyboard, panning with mouse, panning with everything, and nothing worked.


The odd thing is I let the time run 11 minutes as planned, saved and exited the home world, did the next campaign mission, and went back to the Home Realm.  Yes, the camera was due north over outside of the minimap area, but I had no problem this time getting into the playable area.  Once it was back in the playable area, it was like it never happened.

I also just loaded your home realm save and it was fine for me.



So I can not reproduce how it failed.
Is it now permanently fixed for you or does it happen again?


Please let us know if it happens again and if so please save your output_log and upload it here before starting the game again (get's overwritten each game start), so we can see if there was any particular eror causing the problem.

Here is described how to do that http://brightrockgames.userecho.com/topics/118-how-to-submit-a-bug-ticket/

Cheers

It has not happened again.  Was a one-off thing following the Desecration mission.  I didn't grab the output_log when it happened and it was long overwritten by now.  Will update if it happens again.

The output_log usually contains all errors happened during a session so it can be very helpful in finding a cause for an isssue.

Thanks in advance for giving us an update in case you encounter it again.

@Lee
You can try to press "Space" when you hear a notification, if it happens again.
I guess it was a misslocation of the camera

+1

I'm pretty sure I tried space as well as an assortment of other keys and nothing worked except possession.

Cannot Replicate

In that case we will have to decline the ticket. Get right back to us here if it happens again and we will take another look.