0
Completed - Resolved

Steam force closes the game.

jstnhrpr321 2 years ago updated by Cian Noonan (Graphics Plumber) 2 years ago 9

So whenever I start the game up, it will get to load almost the whole way in and then Steam will close it, saying that it is trying to run with optional parameter -force-d3d9. Any way to fix this? I tried verifying my install and it's fine, and my actual launch parameters are untouched.

Game Version:
Steam Public
Platform:
Windows
Pending Customer

We have seen issues like this before which were resolved by simply rebooting the system.
Did you reboot since then and the issue does still persist?

To add to what stefan is saying, what happens if you attempt to continue launch with that parameter

Rebooting has not solved the issue, no. And if I continue to run it just restarts the loop of loading most of the way and then closing for the same reason.

Can we get your output_log? You can find  out how in this guide: How to: Submit a Bug Ticket

I don't get the "parameter" part of it, but Steam quitting the game and restarting it in a loop was encountered a lot in the past.

If it is this problem then it is Steam failing on its own DRM check, so it does not detect that Steam is running and tries to restart the game again with Steam, but failing in a loop again and again.

If it is this issue, in the past it was in 80% resolved by a reboot and in 15% of all cases by reinstalling the steam client.

In only a few cases it was actually caused by an Antivirus programm stepping into Steams DRM check and in another bunch of rare cases a winsock reset was required to make Steam client succeed on its own DRM check again.

But it never was saying "trying to run with optional parameter -force-d3d9" despite there is not even a launch parameter set.

So I am unsure if it is just this or a new issue.
But worth a try to deinstall and reinstall Steam client.
(Your games and your data wont be lost by doing so)


@jstnhrpr321 this looks pretty much like what I said.
It is not an issue with the game it self, but an issue of Steamworks and the Steam Client.
When Steamworks fails to detect Steam client running, it force quits the game and tries to restart it with Steam.

When it then again fails to datect that Steam client is running it will fail in a loop of death.

As said, if a reboot doesn't fix it, likely uninstalling and reinstalling Steam client does.
Let us know if it does.

If not check if disabling Antivirus software does fix the problem.
If not we can link you a step by step tutorial to reset winsock, which can if configured wrongly (mostly by installed Software) prevent Steamworks DRM check from ever succeeding.


Hope this helps!

I just managed to fix it, I realized that I didn't have Steam running as admin. (I should probably set that) Sorry about that!

Completed - Resolved

No worries, glad to hear its working now!