0
Completed - Released

Black Screen After Splash, Compatibility Mode Doesn't Fix It

kkeiper1103 2 years ago • updated by Cian Noonan (Development Support Engineer) 1 year ago 8

I just installed WFTO and I'm presented with a black screen after the splash screen. After following the instructions for Case 3 on Start up Crashes, I still experience the same black screen.


My PC meets all of the Recommended Requirements (AMD A10-7850, GTX 760, 16Gb RAM, 45Gb free of HD space on installation drive)


I've tried starting with -force-opengl, and with -force-d3d11 (separately). Both don't fix it, although when I use force-opengl, I get a pink screen, not a black screen.


Edit

Here's a zipfile of the crash report I get (only generated when forcing opengl; d3d9 or 11 don't generate one)

2017-10-07_112228.zip

Game Version:
Steam Public
Platform:
Windows
Pending Customer

Hello kkeiper1103,


looks like something is preventing our UI middleware (Coherent UI) from starting properly.
> DllNotFoundException: CoherentUI_Native
But this library (CoherentUI_Native.dll) must be surely there.
Could it be that any antivirus or other security software is blocking it?
What windows version are you on?


Cheers

The only security software I'm using is Windows Defender.


I'm running Windows 10 Pro. I tried uninstalling and re-installing WFTO, but I still get the same issue.

Please remove any start paramaters eg. -force-opengl as they are unrelated to this problem.

Then can you try to Verify Integrity of Game Files: https://support.steampowered.com/kb_article.php?ref=2037-QEUH-3335 ?

(Works best after a fresh reboot and while running Steam as administrator)

If this doesn't fix it, can you confirm that in your installation folder of the game
(Library -> right click on "War for the Overworld" -> cick Properties -> Local Files -> Browse Local Files)

actually cointains under

%Steam install directory%\steamapps\common\War For The Overworld\WFTOGame_Data\Plugins
the file named "CoherentUI_Native.dll".
Can you right click it and go Properties -> Security and see if your windows login user is in the list "Group or user names:" and when you selecdt it in the list "Permissions for %Your User Name%" has "Allowed" checked for "Read & Execute"?
If not you have insufficient rights and you should either add these rights or run Steam as administrator.

Please let us know if any of these help.

Cheers

I've removed all start parameters.


When I verified the game files, it said they all successfully verified.


I browsed to the Plugins folder, and the CoherentUI_Native.dll file is present. When I view the permissions on that file for my local user, I have full control.


Also, Running as Administrator didn't fix the black screen.

This is strange, because the issue in your output_log clearly is 
> DllNotFoundException: CoherentUI_Native
so I am a bit puzzled.
Your log also contained other issues likely caused by using " -force-opengl" which is mostly useful on Linux.

Can you start the game without any parameters and upload another log from that session.
Just to have a second sample.
Maybe we will have to ask Coherent Labs why this could potentially happen while the library file is clearly available.

I am sorry that I keep failing to find a proper solution for this problem.

Have you seen an improvement after the latest patch?

Honestly, I haven't had time to try it again yet; sorry. I'll try the new patch tonight and see if that fixes it. Thanks for looking into this.

Completed - Released

Assumed complete due to a lack of response