0
Completed - Resolved

cannot dig - fix the AMD card, now black screen. GOG.com (not STEAM)

vsechnospatne 2 years ago updated by Cian Noonan (Graphics Plumber) 2 years ago 16

Hello, I really want to play this game, but with Intel graphic i cannot dig or click anything and with AMD (as I had followed the setting od dedicated graphic card) I see only black screnn. Sadly, i bought the game on GOG.com, not the steam, so I cannot (or dont know where) to put the -force-d3d9 command.... could you help me?

Game Version:
GOG DRM-Free
Platform:
Windows
+1
Pending Customer

Hi Vsechnospatne


Sorry you're having problems, the developers are currently out of the office (as it's already the weekend in the UK) so you might not get a reply from them before Monday.


In the mean time, I did a quick google (as I didn't know how you do this kind of thing either) and this link looks like it might be able to help you (even though it's for a different game).


In case you can't view the link, it looks like you edit the shortcut (to the game) on your desktop to include the -force text on the end of the shortcut link.


So if you don't mind, maybe give that a try and see if it helps at all?


If not let us know and i'll make sure the devs take a look at your issue on Monday (if not before then)


Hope it fixes it, but if not just drop us a reply and we'll try and assist further.


- Nutter



Nutter, thanks You a lot for trying to help me. I wrote the -force-d3d9 (and the 11 and the 12 variants afterwards) to the shortcut, but screen was as back as before, just music and voice of narrator welcomed me again in dark dungeon (what an ironic man..). I tried to switch to Intel graphic chip, which can run the game and run the campaign, but I can still just stare at the imps running around my dungeon heart and I even cannot slap the not digging running bastards.... so sad..

+1

That's a shame, I was hoping it would be an easy fix. I'll get one of the devs to take a look on Monday morning then.


In the mean time can you post your system specs so we can get an idea what kind of rig you're playing on.

DxDiag specification  hope, this is what you need... :)

Hi again Vsechnospatne


The DxDiag is perfect thanks.


Just one more thing to check, when you forced the game to use your AMD Radeon card did you also ensure that Coherent UI also uses it? A black screen like that suggests that it's Coherent UI itself (which handles all of the menu screens and buttons, etc) that is failing rather than the game itself.


The other thing I should make you aware of now that i've seen the DxDiag is that even your better (non-Intel) graphics card is slightly below the minimum requirements for the game. Your Radeon R7 M370 scores a rating of 1395 on the benchmarking website, which is less than the 1500 rating recommended as a bare minimum so that won't be helping matters either, so if/when we do manage to get the game working i'd expect you'll have to run it on the absolute lowest settings and close as many background programs as possible to play.

Please, Nutter, could you be so kind and tell me, where i can find this Coherent UI to switch it to high performace graphic? I tried to search for it, but i failed.

Thanks

Sorry, found it and doing some experiments already...

Well..... I am defeated. If I let the Game on power saving mode - i can launch it with no problem, but I cannot dig anywhere. If i push it (game and Coherent UT) to High performance, I end on the loading screen with music playing the intro sounds.

Maybe try putting the game on your Radeon card and the Coherent UI on your Intel one. It sounds to me like neither card is powerful enough to handle both processes on a single card, but perhaps if each card handles one job each it might work?

I tried that already. 

I begged, wept, threatened... now I just practice tao. I do nothing. Lets see....

Well, I had to give it a try... I uninstalled the AMD graphic card in system. The game is playable on Intel chip and I can finally dig. :) Graphic is ugly, but I can play the game... tats about the minimum requirements...

Under Review

That's very odd, must be some kind of weird clash between the 2 cards. Atleast you're able to start playing now though.

Pending Customer

Please follow our Missing, Invisible or Laggy UI guide and get back to us, these steps should fix it for you, if not as nutter said you are under min spec and may not be able to run the game 

Hello Cian, I can run the game on weaker of my two graphic chips - thats for the min spec... Problem is, that non of your linked Tips could run the game on my laptop with Intel chip and AMD graphic. The dedication of graphic couldnt fix the problem, nor the combinations with Coherent UI dedication..... I did some search and I am not the only one with this problem....

The game cannot run split across two cards, the processes must be running on the same GPU. If you are getting a black screen that's because the game and ui are on different cards

Completed - Resolved

We recommend playing the game on the highest spec card, if that causes issue then our Unable to click game objects / tag tiles guide may help.