Completed - Resolved

WFTO not starting in Steam OS

dl 6 years ago updated by anonymous 5 years ago 20

Hello Support,

I am running Steam OS in the latest version and have installed WFTO there. I haven't played for a while and the last time I did, the game ran fine. Now, after some months, Steam OS installed an update for WFTO - it's on the latest version now. Since I've installed that latest update, the game does not start anymore.

After starting the game from the library of Steam OS, the screen stays black. When I move the mouse, I see the cursor of Steam OS. The cursor disappears after a few seconds when I stop moving the mouse and the screen is black again. Since the cursor of Steam OS is shown, I guess that the game does not start at all.

Thanks for your help.



Game Version:
Steam Public
Satisfaction mark by dl 5 years ago
Pending Customer

Hi Daniel,

Sorry to hear about your problems running the game since the latest updates. My first thought would be that Steam has failed to update the game correctly, usually this can be resolved by simply verifying the cache for the game.

Beyond that first steps would be to confirm that you've run through the following, although much of them will be irrelevant for Linux based systems just run through what you can:

General Crash Troubleshooting

Startup Crashes

If neither of those articles hold a solution for you then we'll need some extra details, specifically an output log and system specs, please see How to: Submit a Bug Ticket for details.



Hi Lee,

thanks for your reply.

I've forgotten to mention that I've already reinstalled the game twice. Anyway, I've gone through the steps in the docs and verified the cache. The steps are totally different on steam os but I'm pretty sure I've done it right.

The guide also mentions to reinstall the game. Since I already did this twice, I don't think reinstalling a third time would help.

The "startup crashes" guide does not really apply to steam os - I don't think it uses .net and if it does, this is maintained by steam os. I think that it's the mono lib that is used here, hm? Neither do I use any wireless headsets or stuff like that.

I've grabbed the logs from the steam drive and I think that there really is a problem with the mono library. Maybe I should reinstall steam os?

I've attached the logs to this post. I've also created a video so you can see what the problem is, but it seems to be too large to uplad (about 100 MB). I'm currently uploading this to youtube and will link it here ASAP.

Regards and thanks for your help



Hey dl,

Can you verify that this file exists: /home/steam/.local/share/Steam/steamapps/common/War For The Overworld/WFTOGame_Data/Plugins/x86_64/libCoherentUI_Native.so

It looks like you may be missing the C++6 package required by our UI, running this command should download it for you: 

sudo apt-get install libstdc++6

Hello Cian,

thanks for the hint, but unfortunately that's not the cause of the problem. The file exists and the package is installed:

root@steamos:/home/steam/.local/share/Steam/steamapps/common/War For The Overworld/WFTOGame_Data/Plugins/x86_64# ls
libCoherentUI_Native.so  libCSteamworks.so  libGameLogic.so  libsteam_api.so  ScreenSelector.so
root@steamos:/home/steam/.local/share/Steam/steamapps/common/War For The Overworld/WFTOGame_Data/Plugins/x86_64# apt-get install libstdc++6
Reading package lists... Done
Building dependency tree       
Reading state information... Done
libstdc++6 is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 2 not upgraded.

I also ran an apt-get update && apt-get upgrade to be sure that is really the latest version. It is. However, there was an update for steam and steam-launcher. I installed both of them, but that didn't change anything at all. Still the same problem.

root@steamos:/home/steam/.local/share/Steam/steamapps/common/War For The Overworld/WFTOGame_Data/Plugins/x86_64# apt-get update
Reading package lists... Done
root@steamos:/home/steam/.local/share/Steam/steamapps/common/War For The Overworld/WFTOGame_Data/Plugins/x86_64# apt-get upgrade
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages will be upgraded:
  steam:i386 steam-launcher
2 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Need to get 2,757 kB of archives.
After this operation, 21.5 kB of additional disk space will be used.
Do you want to continue [Y/n]?
Get:1 http://repo.steampowered.com/steam/ precise/steam steam-launcher all [2,752 kB]
Get:2 http://repo.steampowered.com/steam/ precise/steam steam i386 [4,944 B]
Fetched 2,757 kB in 1s (1,884 kB/s)
(Reading database ... 84565 files and directories currently installed.)
Preparing to replace steam-launcher (using .../steam-launcher_1.0.0.54_all.deb) ...
Unpacking replacement steam-launcher ...
Preparing to replace steam (using .../steam_1.0.0.54_i386.deb) ...
Unpacking replacement steam ...
Processing triggers for desktop-file-utils ...
Processing triggers for gnome-menus ...
Processing triggers for hicolor-icon-theme ...
Processing triggers for man-db ...
Setting up steam-launcher ( ...
Setting up steam ( ...
root@steamos:/home/steam/.local/share/Steam/steamapps/common/War For The Overworld/WFTOGame_Data/Plugins/x86_64# apt-get dist-upgrade
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
root@steamos:/home/steam/.local/share/Steam/steamapps/common/War For The Overworld/WFTOGame_Data/Plugins/x86_64#

Hey dl,

Could you please try again to play the game with the latest update, 1.6.3. Let us know if the issue persists on that version

Hi Cian,

sorry, I was busy the last few days.

Steam installed an update of WFTO indeed, but after installing this update I'm still facing the same issue. Is there a way for me to verify that steam has installed the update correctly?



The best way to verify is to completely reinstall. Could you please uninstall the game, restart Steam and then reinstall the game. We have added a dependency in Steam so if you do this it should force install the required C++ libraries.

It would also be good if I could take a look at your debug.log found in the CoherentUI_Host folder of your game install

All right, I'll give it a try.

Sorry, could you please point me to the directory where the "CoherentUI_Host" folder is located? I can't find it :(

The log should be here, if you dont have this folder then that would explain a lot as it likely means that large parts of the game are missing

GameInstallPath\War For The Overworld\WFTOGame_Data\CoherentUI_Host\

Well, maybe I'm just looking at the wrong place. Where exactly is the "GameInstallPath" located? As I said, this is Steam OS. The path you have mentioned looks like a Windows path (backslashes). I guess it should be somewhere in /home/steam/, right? If i knew the exact path where to search, I could say if the dir is there in a minute.

On our test machine the path is:

 /home/USERNAME/.steam/steam/steamapps/common/War For The Overworld/WFTOGame_Data/CoherentUI_Host/

Games on Linux are in .steam not steam

The Linux folder at that location should contain the log, if not I will send you a copy of the folder as it shoulds like Steam is failing to install the game correctly.

Cannot Replicate

Without a log we cannot progress, we will open the ticket again once we have received the log


sorry, I've been on vacation.

I guess, by "/home/USERNAME/" you mean "/home/steam/" ? Here is the content of /home/steam/.steam:

As you see, there is not any subfolder.

I case you meant /home/desktop/.steam: This path exists, but it totally empty.

Other directories below "/home/" do not exist.



Sorry, my fault. I didn't see that there is a link "steam" in this path. It leads to the "real" path where the files are located:

/home/steam/.local/share/Steam/steamapps/common/War For The Overworld/WFTOGame_Data/CoherentUI_Host

In the folder "CoherentUI_Host", there is a folder "linux" which contains multiple files. I will now compress this folder and attach it. Is this what you need? You mentioned you need a "debug.log" but I cannot find it there. Here is the content of the folders:



Edit: The compressed folder ("CoherentUI_Host.zip") is too big to be uploaded (more than 33 MB). In the screenshots above, you can see the content. Just let me know what I shall upload.

Pending Customer

Hey Daniel,

Sorry about the long wait, the ticket got stuck in declined and I haven't seen the update until now.

Can you try again on the latest version of the game and see if there is an improvement?

Completed - Resolved

Assumed complete due to lack of response 


sorry for the late response. I do not use Steam OS anymore, but I tried to start the game on Ubuntu and still face the same issue.

I need more time to further check this out, since I want to make sure that this has nothing to do with the hardware. I will try it on another system.



Pending Customer

Let us know how you get on

Completed - Resolved

Assumed complete due to a lack of response