Completed - Resolved

My Pet Dungeon Level 2 Won't Launch

Daniel Scutt 6 years ago updated by Andrew "Nutter" Jaggar 6 years ago 9

Windows 10 64bit

AMD FX-4350 4.2 GHz quad core processor


AMD Radeon 6900 GPU

WFTO V1.6.2fl

I'm about 4/5 of the way up the load bar for level 2 (where it starts to turn pink) and it's stuck. I've tried relaunching a few times, ran the Steam file validation thing, and restarted my computer. I checked for Windows updates and all that, too. I have not tried reinstalling.

Game Version:
Steam Public
Satisfaction mark by Daniel Scutt 6 years ago

To add, the tips on the bottom still scroll by. It doesn't appear to be freezing up completely.

Also to add, I bought this yesterday. So this is the first time I've tried launching it.

Pending Customer

Hello Daniel :)

I'm sorry about the issue you encountered.

However I don't have enough information just yet to find what caused the error.

Can you please follow http://brightrockgames.userecho.com/topics/118-how-to-submit-a-bug-ticket/

and add your outputs log here please ?

Thank you =)

Sorry about that. I also noticed that the bar, when it gets up to where it freezes, it quickly moves backward then forward again. I had another game (Dawn of War) that did this to me a few years ago. When it happened it would launch but the AI wouldn't do anything.


Hello Daniel = )

Can you try installing Microsoft Visual C++ Redistributable 2013:



And report to me if it solved your issue ?

We added a third party software and it might need the 2013 redist, which is new. If it works for you, I will force Steam to install those redit :)

Cheers !

It worked. To note, I rebooted before launching WFTO, and upon launching it popped up with the Steam dependency installation bit, installing some more Microsoft stuff. Not sure what that was all about, but I figured I'd mention it in case it's a multi-step deal.

Oh, and thanks very much!