Completed - Resolved

Game crashes before splash screen

Saladin 6 years ago updated by Lee "Noontide" Moon (Designer & Community Manager) 6 years ago 16 1 duplicate

Puppy Linux Slacko 6.3.0, 64 bit. DRM-free version of game. The console says "Importing game controller configs", then "Aborted", and goes no further.

Game Version:
Steam Public
Duplicates 1
Not a Bug

Hey Saladin,

I'm sorry to be the barer of bad news but we don't officially support non-Debian Linux distros. This means that we cannot guarantee anything other than the game working on Ubuntu and SteamOS due to the complications introduced with some Linux versions.

Ok, I've tried it on Ubuntu 16.4.2, the fifth operating system I've tried so far. Just like all the other 64 bit operating systems, it gets to "Importing game controller configs" and goes no further. Unlike all the other operating systems I've tried so far, the entire OS freezes, and I can't do anything else without pulling the plug.

What do I do?

Incidentally, Puppy Linux is Debian. Certain flavors of Puppy Linux are compatible with Ubuntu too, as they're built with the same packages. Right now, the game seems to be working better on TahrPup, the 64-bit Ubuntu-compatible Puppy than it is on straight Ubuntu. At least on TahrPup, when it crashes it doesn't take the entire OS out.

Do I need to resubmit this as a new bug, or reply to it? I can't find an FAQ here to tell me. I'm just going to reply for now, since I'm not sure I can figure out how to resubmit.

Pending Customer

Ah I'm incredibly sorry, I'm not familiar with Puppy Linux.

Could you link the player.log for the game? If you follow our How to: Submit a Bug Ticket guide you will find the directory that the log is stored at.

Pending Customer

Lets just keep it in one ticket

Looks like you cannot allocate memory, what are the specs of your computer?

Thanks. I think that's the problem. I don't have enough RAM to run the OS live and the game at the same time. I'll have to make a hard disk install, buy some more RAM, and maybe make a swap partition.

Completed - Resolved

For future reference what are you specs, most importnatly how much RAM do you have?

My fault. It's a second-hand computer, and I never actually verified how much RAM was in there. Thought I had six gigs. Turned out I only had three. I've upgraded to eight, but the game still isn't working.

I ran "free" to verify that I installed the new ram correctly: it's saying I have 7910496, so it looks like I installed the RAM correctly.

The game is still doing that "Importing game controller configs" ... "aborted" thing though. The Player.log is still filled with "cannot allocate memory" messages, but "free" (when the game isn't running) is telling me that I have almost six and a half gigs free.


What GPU do you have?

Nvidia geforce 6150se.

Unfortunately that card is far below the minimum requirements of the game. A 10 year old card will not have the power or Video memory required for the game.

Thanks. At this point, I'd rather just cut my losses. I've spent nearly a week and more than $100 trying to get this game to work. I don't have anything else that will benefit from 6 gigs of RAM, a 64 bit OS, or a new graphics card. I'll give it another shot in a few years.

Sorry to hear that Saladin, best of luck for the future and we'll always be here to help if at some point in the future you return with a modern rig :)

For future reference our system specs can be found here: System Requirements at the very least you'll need to upgrade your card (which only pulls a 24! in the G3D test, our minimum is 1500) but not knowing how the rest of your system holds up I couldn't provide a further action plan than that.

We hope to see you again in the future and sorry we couldn't help you get the game running.

Best of luck, hopefully you get to play sooner rather than later