Problem with the new update please help

Timothy 6 years ago updated by anonymous 6 years ago 7

hello war for the overworld team thanks for giving me a piece of my childhood back with this beautiful companion to the dungeon keeper series I have been fairly lucky over he past few months I have had no bugs errors or faults. it is only till tonight when I finished and arrived home from work I had my first error, after installing the new DLC a fiery trail I can not access the game no more the menu loads up with the under lord assistants voice saying welcome back keeper or other quotes, but after this I am greeted with the beating dungeon heart with no menu to access any game mode whether that being multiplayer campaign or survival I know the DLC is new and i am hoping its not just me with this problem I have tried uninstalling the game with the DLC and after re-installation the problem is the same the game has not crashed, the bats and dungeon heart still move and the music plays and the cursor (hand of evil) is moveable but no menu tabs

I look forward to your reply

yours thankfully Timothy Lord

Game Version:

i have tried all of the possible changes my end I have tried the launch tasks and checked my nividia card it is on full and is upgraded to the max I did how ever manage to play about 2 mins of the game and have learned that it is the tabs what are lagging out and not the game I have invisible AI some but not all and within that two mins when I as building I decided to move creatures but the creatures tab yet again glitched I believe I am going to have to wait for a update for a fix to the problem have u any idea when you will be rolling out the next update to solve the bug

yours thankfull tim

Can you please provide details on your hardware and OS platform?

Sorry for the delay ime running off windows ten it's the limited edition Star Wars gaming laptop sorry ime not very good with computer terms ime only just getting used to certain terms I believe it's got intel core i7 and a Nividia GeForce 680 if I remember correctly I have had tom clanseys the division play on it I have gears of war 4 on the laptop and in addition all the command and conquers and dungeon keeper one and two

I only started having this problem when I updated to the current update trial by fire :)

Reguards Tim

Under Review

Hello Timothy,
I would suggest to try the solutions listed in our knowledge base
in 95% it will fix any UI related issue with the game.

Let us know if the steps listed there helped.


Declined due to lack of customer response