0
Declined

Error Failed to Initialize player

daniel_de_freitas 3 years ago • updated by Cian Noonan (Graphics Plumber) 3 years ago 3

When attempting to run the game on steam I get the following error:

Failed to Initialize Player

Failed to initialize Direct3D.

Make sure you have at least DirectX 9.0c installed, have drivers for your
graphics card and have not disabled 3D acceleration
in display settings.
InitializeEngineGraphics failed


I'm running Windows 10 64bit on an alienware laptop with an nVidia 860M graphics card. The drivers are the latest available.

I've attached my dxdiag as well as the output log DxDiag.txt output file

output_log.txt


I've attempted the following:

Validated local files

confirmed executables running in windows 7 compatability mode

ran game as administrator

Validated latest version of .net is installed

confirmed latest version of Direct X is installed

Game Version:
Steam Public
Platform:
Windows

Answer

Answer
Pending Customer

Hello Daniel,
Might it be you have a notebook with switchable graphics: an integrated intel graphics device + dedicated GeForce GTX 860M?

It could be that the game gets assigned to the integrated graphics which is unable to hande the game.
It is either that or the graphics driver is not installed correctly.

Can you try the solutions suggested in this knowledge base article:
http://brightrockgames.userecho.com/topics/1096-missing-invisible-or-laggy-ui/

If it doesn't help, can you try to fully uninstall and reinstall your grpahics drivers?

Let us know how it went.

Cheers

Answer
Pending Customer

Hello Daniel,
Might it be you have a notebook with switchable graphics: an integrated intel graphics device + dedicated GeForce GTX 860M?

It could be that the game gets assigned to the integrated graphics which is unable to hande the game.
It is either that or the graphics driver is not installed correctly.

Can you try the solutions suggested in this knowledge base article:
http://brightrockgames.userecho.com/topics/1096-missing-invisible-or-laggy-ui/

If it doesn't help, can you try to fully uninstall and reinstall your grpahics drivers?

Let us know how it went.

Cheers

Could you give us an update if the linked knowledge base topic did help to resolve your issue please?
We may close unanswered reports after a while.

Declined

Closed due to lack of user response