0
Completed - Released

Multiplayer 1v1 - Client side messed up

Webbernever1 3 years ago • updated by Lee "Noontide" Moon (Community Manager) 3 years ago 12

Operating System
Windows 7 Ultimate 64-bit SP1
CPU
Intel Core i7 4800MQ @ 2.70GHz 64 °C
Haswell 22nm Technology
RAM
32.0GB Dual-Channel DDR3 @ 798MHz (11-11-11-28)
Motherboard
Alienware 041W46 (U3E1)
Graphics
Generic PnP Monitor (1920x1080@60Hz)
Intel (Dell)
3071MB NVIDIA GeForce GTX 770M (Dell) 49 °C
ForceWare version: 372.70
SLI Disabled
Storage
698GB WDC WD7500BPKX- SCSI Disk Device (RAID)
10GB INTEL SSDMCEAW0 SCSI Disk Device (RAID)
Optical Drives
HL-DT-ST DVDRWBD CA40N SCSI CdRom Device
Audio
Realtek High Definition Audio


In short, I was playing a 1v1 with Bohser and pretty much everything went wrong in the game. From gold not being mined to constructs and defences not being built. I started off the game with two cultists refusing to do anything - just standing there. Despite their apparent 'researching', I noticed no increase in my research speed. I later on tried to mine gold with annex. However, the gold never appeared. It turns out later that the gold was generated, but it was invisible. When I picked the gold up and dropped it on the same tile, I was unable to pick up the invisible gold again.


Below, I took a screenshot in which an underminer and bombards were never built. Bohser, however, reported that these were built, but they never appeared as built on my screen. Thus, I was unable to use them.



My minions in the arena, similarly, just stood there, doing absolutely nothing. The screenshot below shows this:


Later on, something more interesting was noticed. Apparently, an imp which I saw on my screen could not be seen on Bohser's screen. I was able to posess it though, and it triggered off Bohser's traps. Thus, for some reason, only I was able to see the imp.


Behold, the alive (on my screen) and dead (on Bohser's screen) skarg!


output_log.zip

Game Version:
Steam Public
Platform:
Windows
GOOD, I'M SATISFIED
Satisfaction mark by Webbernever1 3 years ago

I saw a dead skarg moveiming

Cultist was stuck whilst possessing.

Gnarling and sentinel attacking thin air:



Even though Bohser must have destroyed my dungeon core, it was never shown as being destroyed. I also never went to the score screen.


Here is the final output log. The other output log was sent whilst playing.

output_log.zip

Accepted

Looks like another desyncronisation issue to me, but i'll send it through for the code team to take a look see if there was anything in particular that could have caused it.

I can confirm all issues listed here also happened to me, it seems to be exactly same issue as I reported here: http://brightrockgames.userecho.com/topics/1410-second-playthrough-of-the-same-map-during-mp-without-reboot-causes-numerous-problemserrors/

Not sure if it is related, but this happened today (I could not build monoliths, underminers, or ember rifts on certain squares).

2016-10-22 21-20-22.mp4


I also had a strange message telling me that only hosts are able to change maps...I have no idea how it came about, all I did was type (this was before starting the game). It was fixed easily by selecting a theme/colour.



output_log.zip

The message is harmless and happens when host chose a map you don't have as client. As for the video, I'm not sure what happened. Looks like a potential desynchro on gold, that's the only idea I have at the moment

Ah, I was looking over fixes I made thinking I made something wrong. We improved MP stability recently (for next patch). And Böhser being host, either it's on the public version or there is a mismatch of version, in both case the fixes aren't used. So I'll complete this ticket and we'll see after the hotfix is released ^^

Completed - Next Patch