0
Completed - Resolved

Slaughterpen Pigs ignored by Units after a long duration.

Cron 3 years ago updated by Lee "Noontide" Moon (Designer & Community Manager) 3 years ago 37 2 duplicates

Micropiglets are not spawning for players other than host - tested with few friends in current public steam build. Slaughterpen of any player other than host always says 0/X micropiglets domesticated. Game is unplayable in multiplayer until this is fixed.

Game Version:
Steam Public
Platform:
Windows
GOOD, I'M SATISFIED
Satisfaction mark by Cron 3 years ago

Duplicates 2

Tested with multiple people hosting on diffrent maps. I have heart of gold while my friends dont - not sure if that does matter

Tested with host+client both without heart of gold expansions - its not dlc related since bug persists

Pending Customer

Very strange how this has gone unnoticed thus far. I'll check it over tomorrow when I'm back in the office.


Can you please confirm for me the full specs of your machines as well as output logs from a game session with all players as listed here: How to: Submit a Bug Ticket


Also just in case can you confirm for me that there are no actual pigs in the affected slaughterpens on host and client pcs. Screenshot ideally :)

I used wrong words previously. They are spawning and they are visible... they just dont count. Minions will ignore them and slaughterpen always says there are 0/x micropiglets domesticated.

We tried to play coop when we discovered this bug, but all players other than host couldnt feed their minions.

We tried changing the host, map, playing versus and it always worked only for host. Only host's pigs are correclty counted, all other players get 0/3, 0/12 or whatever their slaughterpen size is


If i mouseover host's or my own slaughterpen in multiplayer game (assuming im playing coop) it says we both have 0 micropiglets domesticated, and its the other way around for host. When host mouseovers my slaughterpen or his own and they are both full for him.


I will try again with a friend tomorrow to get output log and post more info when I get back from work

Under Review

All the information you can gather for us would be great. I'll have a look into this a little later on this week :)

This bug seems to resolve itself once I reload saved game and after ~15 minutes same thing happens

I'm playing last mission of the dlc right now and can confirm because i have same problem, seems to happen only with beasts but cant tell if its related to arena. Some beasts just complain randomly about reaching slaughterpen even thought they are not stuck in any way and slaughterpen is like 20 tiles away


Edit: they seem to get stuck in certain rooms even thought nothing is blocking the way, they just refuse to move outside of them and all of them are 0% food

I tried reloding my save file. This seems to have fixed it somehow...



Ahem...anyway, let me give you my specs as well:


Windows 7 Professional 64-bit

AMD FX(tm) Six-Core 4,3 GHz

16 GB DDR3 RAM

Ge-Force GTX 680 4GB


I can replay this again and record it, so you can see for yourself.

The beasts get hungry, but simply refuse to eat. (Exception being magical meat)


Like I said, reloading eliminated the problem.

Rebuilding my slaughterpen might have the same effect, I will try it.



I can confirm reloading fixes this issue, 10 of my 0% food beasts started moving in line straight to slaughterpen right after loading save


Reloading save seems to be fixing both beast hunger bug and workers not refilling tavern which I reported in another thread. Something is going really wrong when game lasts too long and reload is needed to fix ecountered bugs

I can confirm reloading fixes this issue for a time. After reloading a save workers move straight to my tavern and refill it to 100%. Doesnt last long tho

Yeah, while trying to recreate the bug and testing if rebuilding the slaughterpen also fixes it, I actually stumbeld upon another issue.


I upgraded my beast den, but was unable to attract shadows or bafus.

Tried to rebuild my beast den and threw out all my beast, but it didn't help.

However, the "no food" bug didn't accour this time


I will open another thread and post my output.log if this somehow happens again.



Very unusual indeed.


As this seems to occur in extended games do you have any idea at roughly what point this might occur? Sounds like a couple of weird little issues that have popped up recently. (Perhaps after the Unity upgrade)

Well, I've had a pretty big dungeon by this point. Played for about 45 mins. maybe an hour.

I made a small video and rendering it right now.

Pending Customer

If you don't mind me asking what level are you playing on?

It's a self made map

Pending Customer

Ran some tests today. Pigs seem to be spawning in fine for clients although the slaughterpen's tooltip is simply not displaying correctly for the client. Minions were feeding correctly both host and client side.


It's possible there's another bug that happened alongside this one whereby the clients units couldn't reach the slaughterpen for some reason? That would prevent them feeding.

Accepted

Actually, just confirmed in another test.


After 1 hour of idling on host and client the client's units began to ignore pigs in the Slaughterpen despite there clearly being available pigs on both Host & Client screens.


Replication steps:


  1. Setup Multiplayer on any level 1v1 is fine
  2. For client build two beast dens and a slaughter-pen all 5x5
  3. Idle for an hour
  4. Units should now ignore the pigs
  5. Optional Extra: Slap the pigs as the client, they'll move but not die, no movement on host side.


output_log_Host.txt

output_log_client.txt

    Confirmed in Singleplayer as well. Only seems to affect beasts so far but I'll keep my eyes on the Tavern

    Also now affecting workers preventing Taverns from being filled. output_log.txt

    Just made some tests in multiplayer. The "0/x piglets domesticated" bug is only visual and doesnt affect gameplay. Minions still eat from it - at beginning of the game atlast. Here are screenshots from both client and host of the same slaughterpen.


    slaughterpen-host.jpg


    slaughterpen-client.jpg


    The real bug remains which is minions ignoring slaughterpen after extended period of time (workers with tavern, beasts, not sure what else), in singleplayer i have to reload save every 15 minutes to keep playing but ofcourse we cant reload save in multiplayer so multiplayer remains unplayable until this is fixed.


    Edit: 1 hour to to ecounter this bug seems alot. In my games workers stop filling the tavern after 10-15 minutes. And sometimes when I have 2 taverns they will still fill the new tavern while old one is 0% food.

    Cultists seem to be affected by slauhgterpen bug aswell. Are they supposed to eat only from tavern? Tavern description says only high level minions require it. My level 1-2 cultists were ignoring my slaughterpen today (I didnt have tavern yet). I was getting message that they cant reach slaughterpen even when standing directly in it. After creating tavern they rushed to eat from it and stopped complaining.


    Probably more minions than just beasts and workers are affected, its just not as easy to catch because other minions eat from tavern and dont complain because of it.

    I player some skirmishes and saved each time beasts started complaining about slaughterpen (save description shows time spent in a match). The bug always occurs after 25~ minutes for me

    @Cron, Realised I haven't gotten your System specs yet, if you and your clients could provide that it'd be great.


    I suspect there's some sort of scaling component to this, perhaps based on hardware or what else is happening on the map, my tests took place on a small 1v1 map for multiplayer and on the sandbox hollow map for singleplayer. Perhaps something causes the issue to accelerate in other conditions.


    Yes I would imagine all units are affected by this issue if you do not have a Tavern, Intelligent units will feed from a Tavern instead if you have one, a slaughterpen if not. So eventually they get affected either way but the Tavern oven acts as a small buffer.

    My specs:

    I5-6600k, OC to 4.2 ghz

    GTX 980 Ti

    8GB DDR4 RAM

    Windows 10 64 bit

    We fixed it internally = ) Don't ask me why, but it was related to spirit workers ;) So it will be available on next patch ^^

    Hey, thanks. We gave up on playing until this is fixed so now we can get back to it after patch.


    I have kinda unrelated question while im still here.


    Is there any chance for release of WFTO and its expansion on gog.com in the future? I know you guys already sell drm-free version on your website and humble bundle, but I'm mostly gog.com user so I just wanted to ask. I would be happy to buy it again if that happened. Since both dungeon keeper games are sold only on GOG, I'm sure there are alot people waiting for WFTO aswell.


    We'd love to release on GoG.com and we have been in talks with them in the past. However neither us nor them were willing to release an inferior version of the game to the storefront which the DRM-Free version currently is for whole bunch of reasons.


    While GoG Galaxy is a potential solution to those issues it'd require some significant overhauling to underlying code in WFTO to make sure it all works correctly, something that unfortunately we simply don't have the resources for right now. With that said I don't think we'd count it out and we look forward to exploring the possibility in the future. No promises mind ;)