Pathing issues - minions can't find locations or just stay standing

  • updated
  • Completed - Resolved

I see this was marked as fixed for 1.4, but I am getting major pathing issues on 1.4.2f8.

On large or complicated maps (e.g. Arcane Prison from the Workshop maps), if you dismiss a rally flag, the minions will remains standing where they are and complain about not being able to reach food/lair. I often have to put a rally flag back down the path and then release it.

Game Version:
Steam Public Beta

How would you rate the customer service you received?

Satisfaction mark by rlund 8 years ago

Add a comment about quality of support you received (optional):


Save Games

I added some save games. Check some of the minions in the Northwestern area of the map.

If you place a rally point there and then dismiss it, the minions will just stay in place and ignore the facilities that are not too far away. I even opened the shortcuts from the dungeon core to these locations to maybe allow them to use those paths.

Also, somewhere between save games, I encountered one minion who was getting angry because he couldn't sleep. I placed him in two lairs with open spaces - he just stood there and kept being angry, but refused to lay down and sleep. He was a converted unit from the enemy, so he was not a beast.

I'm not sure if this second issue is related, but given that he stopped moving, chances are good that it is related.

Please let me know if I can provide more information or if you'd like me to run tests - I'll keep the save games.

Lee "Noontide" Moon
  • Under Review

Tagging this for review when we're back at work next week.

Ryan Cosford

I have same error... Not on same map but during campaign. I find I have to either pick up creatures and then Instantly drop. Sometimes slapping or using recall works.


Oh, right, that reminded me:

On the same note, I can drop off one of my workers in a tile belonging to me and neighboring a tile I want it to convert - and then it does nothing. If I turn my screen and slap the critter into the space, then it will start working. All part of the same thing, I guess.

Again, I'm more than willing to help with this if I can.


Lee "Noontide" Moon
  • Pending Customer

While I've got a moment to pop on, we definitely want to look into this further so a good thing for you to do now is to give this article a read: How to: Submit a Bug Ticket

Have a read through and think what extra details you can include. In particular the very least we'll want in addition to the awesome save you included is an output log from when the error occured and your system specs.


Output Log

Thanks. I have encountered this consistantly on two computers, so I'll add the system specs of both of them:

1. Computer:

OS: Windows 8.0 64bit

CPU: Intel i7 3.5Ghz

RAM: 32GB, 20GB of them tied up in a virtual disk for Windows swap file, leaving 12GB

GPU: nVidia GeForce GTX 660 Ti, 2GB GDDR5 RAM

Build: 1.4.2f8

2. Computer:

OS: Windows 7 64bit

CPU: Intel i7 3.5GHz


GPU: Intel HD Graphics 4000 (on motherboard)

Build: 1.4.2f8

Please let me know if I missed anything.

Lee "Noontide" Moon

Thanks for those Rlund, I'm afraid we won't be able to look at this during the course of this week as we're rather swamped at the moment. But I'll be sure to get someone to look at it soon.

Out of curiosity have you only experienced the issue on workshop maps? Usually this kind of thing should be accounted for but we did used to see something similar when there just wasn't enough resources to go around on the CPU, but I wouldn't expect that from a rig like yours.

Lee "Noontide" Moon
  • Accepted

No rush, I can only imagine how busy you guys must be (I'm web developer, so I get it).

Unfortunately, I actually don't remember if this has happened on other maps, too... It might have, but I've had a very busy time and don't remember much that has happened...

But the good news is that you're giving me a reason to start over on the game :-)

I'll let you know if I run into this during a campaign and will create and attach a save game ASAP.

Oh, and while I'm at it: Thanks for making this game!!! I'd been hoping for DK3 for a while, but I am much happier with a game made out of love for the original than with anything that I'm sure you-know-who would have made as a sequel... Thanks!


OK, I encountered something related (hopefully) during the campaign (Map 6, Behind Enemy Lines).

I zoomed the camera into the position where it happened - hopefully it'll work in the save game. It's the very North of the map.

I put down a rally point and got my minions into the last area. Then I moved the rally point, and some of my minions just stay put even though the new rally point is really close to them. I can continue to move the rally point, but they'll stay put.

Once I slap them or pick them up and drop them, they start moving again.

I've had that happen in other areas of the map, too, but not with a rally point set.

It is interesting that they will move to the rally point for some time (across the entire map), but then in the last few changes they'll stop.

I'm wondering if they're on drugs since they seem to be very happy there (smiley faces showing) ;-)

I hope this helps.

Save Game 2