0
Completed - Resolved

Games Crashes after splash screen and load bar complete. Steamworks not intialized?

Phil Brangers 3 years ago updated by Bigblueelf 3 years ago 3

I have uninstalled and reinstalled twice. I haven't had any issues with any other steam games, only WFTO.


os X El Capitan

64 bit

2.4ghz i7

16 GB Ram

AMD Radeon HD 6770M 1024 MB


Player.log
Game Version:
Steam Public
Platform:
OS X
Pending Customer

This is not a "Crash" but the game shuts down because Steamworks can not initialize.
The problem comes from an issue where Steamworks fails to realize that Steam is running and thus fails to initialize so the game can not work and shuts down with this message.
Many Steam games might not suffer from this issue because only some games on Steam actually use Steamworks.
Do you have games which use Steamworks that actually work?

This problem pops for some people from time to time.
Like here:
http://brightrockgames.userecho.com/topics/4-critical-error-steam-initialize/

However in almost all cases it was resolved by:
- Either simply rebooting your system
- Reinstalling Steam client (and not the game)
- In rare cases by resetting TCP/IP because any program(or user) modified it so Steam ports coouldn't be used

However we also have an issue with OSX startup crashes for some people due to an Unity issue.
If you suffer from this please read:
http://brightrockgames.userecho.com/topics/1256-os-x-crash-on-startup-v140/

I hope this helps!
Let us know how it goes.

Completed - Resolved

Assuming complete due to lack of customer feedback.

I have a simpler thing. If I open the game in steam I get the loading sign (circle going around and around) and I A) can't click anything but the keyboard still works (I can un-pause and re-pause VLC and I can tab to close the game) or B) I get a black screen and as soon as I click it turns white and I'm asked to wait or close the program.


If I run it from the folder I can get the logo or skip it and have it load till the bar fills and then quits and reloads leading to A or telling me that it can't run the game. It's all ready running.


I know it worked years ago coz I got up to lvl 3. AND I know it works coz my brother is playing it now with no problems.