Completed - Resolved

After 1.4.2 update I can not load some saves

adfs sdfa 6 years ago updated by Lee "Noontide" Moon (Designer & Community Manager) 6 years ago 65 8 duplicates

After 1.4.2 update I can not load some saves. For example, I can load saves where I played 3-4 hours, but can not load saves where I played 5-6 hours. The game crashes with r6025 - pure virtual function call error after loading almost come to an end. Look on a screenshot. Also I uploaded one of those saves.

Game Version:
Steam Public


Completed - Resolved

Hi all. Hotfix 1.4.2f5 has now been pushed live to the public branch. Publictesting branch is now closed so you'll automatically be moved there if you opt in.

Marking this as complete based on feedback that the issue is fixed in this hotfix :)

Duplicates 8
Under Review

Very unusual indeed, please can you provide all the information as requested in this topic: How to: Submit a Bug Ticket

Can you both also make sure you've followed the instructions in: General Crash Troubleshooting

Things in general troubleshooting:

  1. Did it, crash with runtime exception
  2. Did it, same
  3. It’s not a startup crash
  4. Not gonna delete and re-download the game, sorry

Win 10 pro (build 1607), 64-bit, 16 gb ram, nvidia gt 840m (drivers 368.81), i5-4210u 1.70-2.40ghz

Game version 1.4.2f2

Crash happens when loading save files with long playtimes and many units.

All other files are attached in the zip file, no crash report generated by the game. wfto-hog bug track files.zip

Merged related topics. Please read the above comments and provide requested information. I'll have the code team look into this thread :)

1) Windows 10 pro x64; 8 gb RAM 2400 mhz; GTX980Ti (drivers 368.81); i7-4790k 4.40 ghz
2) Game version 1.4.2f2
3) 123.zip

Hi Guys,

Just a heads up, we've identified a couple of cases where crashes such as this could occur in the current build. It seems that the Unity version used to build this patch had some underlying issues which has caused this to crop up on a few stages and with a few save files.

We've updated to the latest version of Unity internally and we think that the cause of these crashes should be fixed. However we cannot roll out a hotfix just yet. Sadly updating Engine can cause some unusual issues of it's own and we've already identified a couple that have come along with the new Unity version.

So here's our plan of action. Over the weekend and early next week we'll be QAing the internal version of WFTO to check for major issues, then provided all is well we'll look towards releasing a public beta so those of you who are affected can get access to your levels and saves again.

In the meantime please keep uploading your info and saves if you're suffering from this issue. I'll let you know if/when a public beta branch is made available with the changes.



Can we downgrade the version of the game from steam to 1.4 minus the 400mb patch?

I've made v1.4.1 available on the previous build branch. You can opt into it via the betas tab on Steam. :)

Give it a go and let me know if you can load the levels again and of course be aware that it will not include the fixes that are in v1.4.2


Downgrading to 1.4.1 worked, save file loaded perfectly.

Yes had same problem with Win8.1 on v 1.4.2 & falling back to 1.4.1 loads the previous save 100%

Completed - Next Patch

Should be fixed next patch then hopefully once the new Unity version export issues are solved.

Tentatively marking as "Completed - Next Patch"

I have the same problem :(

Keeping this as accepted until we open public testing for the hotfix. For some reason Steam is now not accepting new builds from us!

im getting exactly the same error even practically the same error.log :(

Same problem. I'm a new player, but I haven't been able to load any games whenever i've needed to save. In particular the last stage where you're forced to swap maps in the first campaign. The last stage can't be finished because the map swaps always crashes me if I'm trying to load a homeworld i've tried building up.

Win 10, 64-bit, amd fx-8350

16gb ram, nvidia geforce 660

Game version 1.4.2f2

I've tried restarting and all the general crash fixes in the forums.

Hi Trajan,

Sorry to hear you've been affected by this problem, as I've outlined a bug we've not been able to pin down why it occurs for some users but we do know it is a result of the Unity Version that built the game during the latest patch.

This issue is currently worked around by rolling back to Patch 1.4.1 which was built on an older version of Unity, you can do so via the betas tab on steam. We're also looking to release a public test version of the upcoming hotfix tomorrow. Which you will be able to opt into once it goes live.

Under Review

Hi Guys, I'm going to merge this with a related thread. We're rolling out a hotfix for public testing tomorrow, but for now you can rollback to Patch 1.4.1 using the betas tab on steam.

How to toll back? Uninstall and then install again?

No need to uninstall-reinstall, open steam, right click to the name of the game, select the "properties", then go to "betas" tab, in there it says select the beta you'd like to participate to "previousbuild 1.4.1"

Just to say, I'm having the same issue :o(

Currently rolling back to previous build. Will say no more if it fixes!

The rollback fixed it for me :o)


Hi MarAri,

Apologies for the late response, I've not been too well lately.

I suspect your issue is in fact related to another issue. I am merging your thread with that one. I advise rolling back to 1.4.1 as a temporary work-around but we're hoping to rollout a hotfix soon that should correct the issue.

The problem is every time, when I load in the map editor my map.

Pending Customer

Can you try rolling back to v1.4.1 via the Betas tab on Steam and see if this issue still occurs?

Yes, in version 1.4.1 there is no problem.


This is related to another issue which is all the result of the Unity version that was used to build Patch 1.4.2, we're working on a hotfix currently (In fact it's done but at the moment we're having issues delivering the game to Steam)

We'll keep you informed on when the hotfix goes live on public testing :)

Update. Game breaks when I try to edit ANY MAP! I can't use the map editor.

Pending Third Party

Hi Guys,

Just to keep you informed I'm afraid the hotfix will not be coming for the time being. For the past three days we've been wrestling with a compiler issue in the latest version of Unity (The one with the hopeful fix for you guys) unfortunately this version of Unity is not able to build the game for release on Steam at all.

Unfortunately this means we're now marooned waiting for Unity to fix the issues in their compiler before we can build a hotfix for you. It's good that we know rolling back to v1.4.1 is an effective workaround for those affected by this issue but we recognize this is not ideal. We will push Unity for a fix and keep you informed when we can roll it out.

Apologies to all who are waiting on this patch.



I'm posting to report that I had the same issues. Loading Heart of Gold saves on Level 1 and 2 caused crashes (though Original campaign maps seemed fine for me), where I didn't have any problem before, nor did I have any problems starting those levels anew. Rolling back to the previous build seems to have corrected this though!

restore to previous build fixed the issue

Okay I was not finished. I would not had thought that the system would finish my message, just becouse I inputed my email.

Anyway. Whenever I load a saved file it chrases. It does not matter which map or which saved file(I tried to make a new save file).

Even when I tried to reenter my home realm it chrases, which meant I got cheated out from the final cut scene at the end of the normal campaign, since the game needed to load my homerealm. The message I get is the one I have filled into my message error.png.

I hope you can help me.

Best regards


I have exact the same issue.

Under Review

Hi Jonas,

I suspect this is related to the known issue in this knowledgebase article: Crash when loading a save / loading certain skirmish maps / map editor maps (Patch 1.4.2)

Please give that a read for the full description of the issue and workaround and confirm for me if the workaround resolves the issue for you.

It worked. Thank you


Great to hear, I'm going to merge this into the related thread. It'll keep you updated on when the hotfix is deployed. :)

Can't load any save games. This happened after Windows 10 did an update

Pending Customer

Hi Debbie,

Likely related to this: Crash when loading a save / loading certain skirmish maps / map editor maps (Patch 1.4.2) please give the workaround a go and let us know how you get on.

Hi Debbie, I have replied to your comment on the knowledgebase article. Please review it and let me know how you get on.

Pending Customer

Hi Guys,

I've just uploaded v1.4.2f4 to the Public Test Branch which you can opt into. Please can you give that build a go and let us know if your issue is still resolved. (Please note there's only a 64-bit windows build thus far due to our issues with Steam)



Opted into the v1.4.2f4 beta and now I can load my old Heart of Gold saves. However theres a few problems with the saves. Problem one is that my player/dungeon color has changed from gold to green, like in the normal game campaign. Not too big of a deal, purely aesthetic I guess. Problem number 2 is game breaking however, the narrator(Mendechaus) has completely gone silent and quest progression is frozen because of this. Any cutscenes will just stay in cutscene mode eternally and will not progress. He will not be able to inform you of any changes in questline either. Enemies are also silent and don't talk to trigger new events.
I've only tested with my old saves from 1.4.2 so far, so I don't know if making new saves and loading them will be fine. I'll try testing that later on when I have more time.
Thanks for the hard work you guys are putting into this!

Hi Vaz,

Please can you upload affected saves for us and an output log from a session where you load it.



Hey Lee,

Sorry I forgot to include the save, I'll do that now.
Also, I tested creating a new save on 1.4.2f4 and I tried saving every few minutes and reloading to see if it would get messed up. First of all the narrator still disappears and cut scenes get stuck in infinite mode. I discovered that saving during the cutscene and reloading seems to fix it by cycling through all missed dialogue until everything is caught up. It also seems that after reloading the save a 2nd time the player color again changes to green and the narrator stops talking again. I tried verifying steam cache and nothing happened, nor did it fix the problem.

I've included both the pre 1.4.2f4 save and the save I just made today after having the beta branch installed. I hope this helps. If you need any further info/data please let me know!

Thanks for that Vazeul,

I've tried replicating the issues you described but unfortunately I didn't have much luck with the Narrator "Dissapearing" and cut-scenes continuing infinitely.

I did however manage to replicate the colour change and this is something we've seen before so it seems whatever change happened in the new Unity version undid a fix we previously made.

For our next steps can you provide step by step replication steps for your first issue. Including what level you attempted it on and during which cutscenes, how many times you need to save for it to break. I'll also be passing on the save file to our code team so they can take a deeper look into it :)



Quick question as well, did you alt tab at all during the cutscenes, or move focus from the game?

Actually just confirmed this issue on Level 13

Nano for you when you look into this:

1. Start C13

2. Reveal the map and save

3. Load

4. At some point Mendecaus should finish a line and then stop, after this point no other lines will be triggered. Alerts are suppressed and cutscenes will become stuck

Suspect MQ is falling over for some reason but it's rather unusual because it's not always at the same point in the chain.


13 equilibrium_20160901123504

13 equilibrium_20160901123504.meta

I have not tried alt tabbing at all, and I play in fullscreen. So that shouldn't be an issue. Unless Steam or Skype notifications are triggering some issues. I'll keep an eye on that from now on.

It seems to be not so much a matter of how many times I save the game, but more how many I load. For some reason If I load the game once it works perfectly, but on the 2nd load is when everything starts getting messed up. It seems I can save to the same slot as many times as I want throughout the mission, but if I load that specific save slot twice then it messes up. However, if I start a new game on a different map, or even the same map, and overwrite the save it goes back to normal until I load that map twice.

As far as Mendecaus going silent, it kinda happens randomly. Sometimes he'll be talking for the first half of the mission. Sometimes he won't even make it to the first cutscene before he goes away. So far from what I've seen time spent in a mission is irrelevant. So far saving and loading the game in the middle of a cutscene for me will fix it and he'll go through all the dialogue in the save that he didn't say (this can sometimes take a while to get through because he'll start rambling off notifications before he gets to the actual event dialogue to progress the cutscene).

Lastly I tried finishing my mission 13 save earlier before coming back to check this thread and Mendecaus disappeared on me there too. Can't finish the mission because the cutscene at the end just hangs. So it seems to be happening in both main campaign and HoG campaign.

So far the only 2 levels I've tried it on have been mission 13 and HoG mission 2. I can go play around with some other missions later and see if problems persist there.
Edit: Here's my lvl 13 save with log.

Hi Vazeul,

Thanks for the further info, this one has been a real headscratcher. We've made a small change to how the scripting engine works and in my attempts to replicate as I did previously I wasn't able to do so. I've made v1.4.2f5 live on the public test branch now. When you've got a moment can you pop on and see if that's resolved the issue for you, we tested for several hours yesterday and weren't able to get the same result again.




I also have a save that crashes when loading in the official build with the difference that it was created BEFOR the 1.42 build. I dont know the exact build anymore but it was created on July 18th 2016. It crashes to desktop with the error 'WFTOGame has stoped working'.

So i opted into the public testing version and tried to load it again, and it WORKS. (shame i cant get the missing achievement i prepared that map for on the public test tho so bit more waiting)

Anyways I've included my saves, may they help figuring out the cause for the crashes.

The rar contains 2 saves of the Heart of Gold DLC level 3. both were made in preparation for the 'More Money than God' Achievement.

One called "02" were i still have most of the rooms and minions and all the gold i dug. This one is/was working and loading just fine.

The other one called 'Gold Achievement HoG lvl3' is the one that would crash. In this save every minion was discarding except the 5 base workers and the 12 permanent spiritual workers u get from the various artifacts in the level. Every room is sold except for the vault which covers every digable tile. All the gold was spent. The main objective of filling the forge is NOT completed.

Also, like others have experienced, the color on the minimap changed from gold to green.


Cheers and keep up the good work, awesome game.

EDIT: Specs are WIn7 Prof SP1 64bit, intel i7 X980 6x 3,33 GHz, 12 GB RAM, Zotac Geforce GTX 580 Amp Edition

Hurray it's fixed! I managed to finish out my save games without getting stuck on cutscenes. One of them did hang for a minute with silence but eventually fixed itself(could just be lag on my end). It seems that whatever you changed in the last beta branch patch fixed the issues for me. I played through 2 of the save games I have posted here in this thread without issue.
Big thanks to you developers for your hard work! And thank you Lee for your frequent responses and updates!
Now I'll be off to finally finish my HoG campaign!
Thanks again,


Hi Memno

This is a known issue, you can find more information and the current workaround at this link on our knowledge base.

Completed - Resolved

Hi all. Hotfix 1.4.2f5 has now been pushed live to the public branch. Publictesting branch is now closed so you'll automatically be moved there if you opt in.

Marking this as complete based on feedback that the issue is fixed in this hotfix :)