Completed - Resolved

Selected blocks appear black instead of blue (linux)

Gwendal 7 years ago updated by Scott Richmond (Programmer & Producer) 6 years ago 25 1 duplicate

Game version: 1.4.1f1

OS: (Linux) Fedora 24 64 bits

Graphic drivers: Nvidia proprietary drivers 367.27

When I select blocks for carving, they appear completely black like this;

Image 1200

I have tested on the computer of a friend running Windows, and the result I expect is the blue coloring like this:

Image 1201

Here are my graphical settings:

Image 1202

I have tried to play with most options, with no result.

Thanks in advance :)

Game Version:
Steam Public


Satisfaction mark by Gwendal 7 years ago
Duplicates 1
Under Review

Hey mate. This can occur sometimes due to bad GPU drivers. You may need to look into updating your GPU drivers or switching driver type.

Pending Customer

Once you've done that can you let us know if you've had any success. In the meantime I'll set this as Needs more Information.

Completed - Resolved

Closing due to lack of customer response.

Sorry for the lack of response, I did not manage to downgrade my drivers, so I am waiting for a driver update to see if this fixes the problem. I will re-post a comment here if I have news.

Setting See-Through Highlighting=False in Options.txt does not help

This also happens on my laptop, which has an Intel GPU.

Pending Customer

Hi YS1,

I've merged your ticket with a related one. Please read the comment from Scott above and see if it helps. In the meantime I'm going to set this back to pending customer.


my drivers are up to date, on both systems.

The fact that this bug occurs on three systems with different GPUs leads me to think that the problems lies elsewhere.

Is there a way to get a more detailed (debug) log ?

Could you upload the log file from your NVidia machine? (See this article on where to find it: https://brightrockgames.userecho.com/topics/118-how-to-submit-a-bug-ticket/)


Not sure whether it uses the Nvidia card or the integrated intel, though.

I have just tested with a completely different computer (a laptop) but with the same OS, and I encounter the same issue, see the following screenshot:

Specs of the tested system:

  • CPU: Intel(R) Core(TM) i5-4210U CPU @ 1.70GHz
  • No dedicated GPU
  • 12 GB of RAM
  • OS: Fedora 24 64 bits, kernel 4.6.3

Can you please provide your Player.log for this session?

Here you go, I hope it's the right file, but it should be the right session since I haven't restart the game since: Player.log

Can you confirm for me you're using the latest drivers for Intel GPUs as per here: https://01.org/linuxgraphics/downloads

Here is what I have:

  • Kernel: 4.6.3
  • Mesa: 11.2.2
  • xf86-video-intel: 2.99.917
  • libdrm: 2.4.68
  • libva: 1.7.1
  • cairo: 1.14.6 (upstream is 1.15.2)
  • xorg: 1.18.3

So fedora is just a little behind regarding cairo, but everything else is up to date. I'll see if I can try an early test package with a the version from upstream.

Here is the log file obtained on the computer mentioned in the original post, which uses a Nvidia card:


I've started the first level, clicked on a few blocks (which appeared black), and did Alt+F4.


Good news! We believe we've found the bug and will endevour to push out the fix this week. We'll keep you posted.

Great news indeed :). Thanks for looking into it! I'll test the next patch as soon as I can. If there is any way to test in alpha/beta stage, I can also do that.


I confirm that the issue is solved at least with Intel drivers. Since it didn't seem related to specific hardware, I suppose that it is solved for all cases. Thanks! :)


Yes, this works for me too. Great !


Awesome! Our apologies it took so long to get this patch out. Hope you enjoy the game. :)