0
Pending Customer

possession spinning

sophontteks 1 month ago updated by Lee "Noontide" Moon (Designer & Community Manager) 4 weeks ago 1

When I enter possession mode I am receiving continuous UP and LEFT inputs, resulting my the character staring at the ceiling whilst spinning. I've read similar bug reports, but I do not have any other input devices plugged in.

- I disabled bluetooth to remove the steam controller
- Unplugged PC game controller
- Removed input devices from X360CE emulator
- Deleted xinput entries in gam registry
- Set Steam input to "force off"

Nothing has had any impact. Is there any way to completely disable controller input?

Game Version:
Steam Public
Platform:
Windows
Pending Customer

Hi Sophontteks,

Some thoughts:

  1. Try unplugging all extraneous USB devices that aren't your keyboard or mouse. This typically happens if an input device is sending a non-neutral input. I've seen examples of Racing Wheels, Controller Adapters etc. all sending such forms of input
  2. Disable entirely any emulation software for controllers
  3. Disable game controllers via device manager

Something you can try to disable this input in WFTO is holding down Alt while booting the game, this will bring up the unity config menu. You can try unbinding the controller axis' on this screen.

Let me know how you get on. In any case this does come up ocassionally for some users so I'll ask if we can have a more robust solution or simply remove controller support from possession in a future maintenance patch.

Thanks,

Lee