Completed - Resolved

Not receiving credit for Completionist Achievement

puppehgal 5 years ago updated by anonymous 5 years ago 7

I've replayed this level about five times now and I haven't received credit for the achievement despite claiming all three shrines. I have ensured to claim them all before destroying the other dungeon core and the crystal, and have made sure to place both warding totems and outposts and I also made sure to kill all empire forces on the map, triggering the V/O announcement that I have done so.

  • Windows OS
  • Version 10
  • 64bit
  • 16.0 GB ram
  • NVIDIA GeForce GTX 760 GPU
  • AMD A8-7600 Radeon R7 CPU
  • Game version 1.6


I hope I got everything you need in there.


Game Version:
Steam Public
Pending Customer

Hi Puppehgal

Slightly random question, but just to be sure. When you say you've replayed 5 times, is that 5 plays from the same save game? Or 5 brand new fresh plays from the very beginning of the mission?

It's possible that somehow a save game hasn't stored the state of one of the shrines properly, meaning that as far as the game objective is concerned, the shrines aren't all claimed. It's the only thing I can possibly think of that could cause this, as Bohser tested this for us a few days ago (as you may have seen on the steam discussion)

If it is a corrupted save game, i'm afraid the only thing we can suggest is a fresh playthrough right from the beginning of the mission (and if possible try and complete it within one sitting without saving and loading).

Hopefully it's not a corrupted save game and we can do more to help, but we'll know more when you let me know if you've tried a fresh playthrough yet.

I replayed all missions from the start, no joy. I also reset my campaign and still didn't recieve credit.

Huh very odd.

Would it be possible for you record you playing the level and upload it somewhere? That way we can hopefully something you may be doing differently to our testers to spot the problem. Failing that could you upload a savegame?

It's not great quality but I hope it's sufficent.

Pending Customer

Hi again Puppehgal.

I watched your video, by the looks of that completion screen you've already got the achievement in question which is why it's not being awarded again. It sounds like an obvious thing to ask... but have you double checked the steam achievements page? I tried to check myself for you but your profile is private so i wasn't able to do so.

I know the icon for that achievement is pretty grey compared to the other, but when it is uncompleted it has a lock icon over it, and when it gets unlocked it has purple bits on the corners. At this point my best guess is that somehow it got awarded without you noticing and that's why it's not unlocking again.

Can you double check your steam achievements page for WFTO, and if possible upload a screenshot showing that particular icon (either with or without a lock on it)



... Oh my god I feel like such a tool, it's there in my steam badges. Since I didn't get a pop-up and it was grey I just assumed I didn't get it. I'm so sorry for wasting your time like this ><

Completed - Resolved

Haha no worries puppehgal, come back if you have any other issues in the future!