Heart of Gold/1.4 has reverted to version 1.3

Roysten 7 years ago updated by Jan - Eric Merzel 6 years ago 7

I successfully downloaded and ran the new update yesterday, I played it several times over the course of the day.

This evening when I tried to load the game I think it installed some hotfixes, then when I loaded the game it reverted to version 1.3.

On Steam - properties - DLC, it says I have everything installed, so I'm at a bit of a loss as to why it suddenly doesn't load as it did yerterday.

Game Version:
Steam Public
Under Review

can you please verify the game via the Properties under local files?

It said that it is verified 100%, under the DLC tab it says that everything, including HoG is installed.

and this issue still persists? im actually quite confused by this.

can you check you beta tab under properties and check if you are somehow opted into one of our Old beta builds?

hrm ...

are you on a 64-bit or a 32-bit system?

if its the latter we may have a faulty build but reports on those are rare by now

Pending Customer

I believe there was a random 1.3 patch that got uploaded somehow but later patches should have fixed this issue (with a new 1.4 build replacing the old 1.3 build you mistakenly got) can you confirm that's the case now?

I am on a 64-bit system, Windows 10, i5-2320, plenty of free harddrive space, Steam is set to install update automatically.

Between it working and not working no settings had been changed (by me at least). I have been opted into some beta testing, I believe it was "public test branch 1.4", I have since changed this to see if it makes a difference, so far it hasn't, I'm currently changing it to the "NONE" option, sadly it looks like it's going to take hours to complete the downloads before I can check again.

I browsed the local files and the WFTO exe (at least the one in the C:\Program Files (x86)\Steam\steamapps\common\War For The Overworld directory) hasn't changed, though obviously I don't know whether it's the exe or other files that dictate what version it is that actually runs.

Let me know if I can give you anything else that would be useful.

Right... the switch to not being involved in any beta projects finished, I got a weird error message about a corrupt download (sorry I didn't read it properly I thought it was an ad popup), the message didn't stop or reset the download or anything. I ran the game when it eventually finished.. and I'm back at HoG again.

Really don't get it. I'd appreciate any insight if anyone has any. Please don't close this off quite yet, I want to run it for a couple of days just to make sure it doesn't misbehave again.