Completed - Resolved

MacOS Monterry works one day, won't load the next

Dylan Vanderhoof 1 year ago updated by Lee "Noontide" Moon (Designer & Community Manager) 1 year ago 5

OS: Mac

Version: 12.1

RAM: 16G

Graphics: AMD Radeon Pro 5500M 4 GB

CPU: 2.3 GHz 8-Core Intel Core i9

WFTO version: v2.0.8

Things were working just fine last night.  Today, with no other changes, I cannot even load the game.  It gets about 2/3 through the loading screen before stopping.  Eventually it crashes out.  

Error in Player.log (attached) is:

src/common/pipes.cpp (883) : fatal stalled cross-thread pipe.
src/common/pipes.cpp (883) : fatal stalled cross-thread pipe.
src/common/pipes.cpp (883) : Fatal assert; application exiting

I've restarted the computer, reinstalled WTFO, and tried the previous version, none of those things helped.


Game Version:
Steam Public
Mac OS 12.1 Steamworks Crash
Pending Customer

Hi Dylan,

Sorry to hear you're having issues with the game. I've never seen that error before and it looks like it's not part of our codebase that's firing it off... I'd be a bit concerned that it might be something in Unity otherwise it's possibly code used for a third-party plugin. .cpp means C++ while Unity's script 

That something like this would suddenly start falling over suggests there's been a change somewhere along the line. As we've not pushed any updates since August it's certainly not a change we've pushed. I note that Mac OS v12.1 is a recent release (December?) I wonder if your Mac updated to a new version and with this it's broken something fundamental used here?

Are you able to confirm whether there were any software updates on your side when the game broke? Update history on Mac OS?

In the meantime I'm going to mark this down as something for us to look into as soon as I can get some code time resource on WFTO. (It's in maintenance mode right now)

I'm currently on holiday until Wednesday (New Years and all that) so I'll try to look into it a bit further when I'm back at work and ask around. 

A very quick google shows this problem pops up for quite a few games running on different engines and I found some reference that this is a Steamworks issue (Valve's API for Steam). About 2/3 through the loading bar is when WFTO checks for Steam so that seems to possibly add up. A user I saw having this issue with another game simply had to restart their steam client and the issue was resolved. Maybe give that a try and update me. :)



Hello Lee!

Thank you for the response. 

Good call about 12.1, I did upgrade from 12.0.1 to 12.1 on 12/31, and WFTO last worked on 12/30.  That seems the likely culprit!

I've tried restarting the Steam Client, rebooting, and reinstalling WTFO.

Agreed, I'm seeing others with this error and it is almost certainly related to the Steam check, but none of my other Steam games seem to be having this issue.  


Thanks for confirming Dylan, I'll log this as an urgent issue to investigate for the next maintenance pass. It might be the case that it could end up being fixed on Apple's side or we might need to see if there's an update for Steamworks on our side.

I don't think we have an Mac in the company anymore so it might be a little while till we can test internally and confirm. I'll try to keep you posted.

Quick update on this:  This was defintiely a 12.1 + Steam Client issue.

A subsequent update of the Steam client that was pushed in the last couple weeks appears to have resolved the problem.

Completed - Resolved

Hi Dylan,

That's brilliant, thanks for letting me know!