An exception was thrown by the type initialiser for Galaxy.Api.GalaxyInstance

Avatar
  • Views 3,898
  • updated
  • Pending Customer

Just bought a game and it does not work. Installed with Gog Galaxy. When I run it - loads, but then shows an error
"An exception was thrown by the type initialiser for Galaxy.Api.GalaxyInstance"
Apple M1 2020
macOS Monterey 12.0.1

Game Version:
GOG Galaxy
Platform:
OS X
2.0.8 Startup Crash
Avatar
Yevhen

There is this thread https://support.brightrockgames.com/uk/communities/1/topics/5733-game-does-not-start-gog-mac
but how do I download older versions of GOG Galaxy?

Avatar
Lee "Noontide" Moon Designer & Community Manager
  • Pending Customer

Hi Yevhen,

Sorry to hear you're having trouble with the game. Sounds like you've already found a similar ticket which had the same issue with our currently recommended work around.


To roll back your game to 2.0.7 do the following:


  1. In your "installed games" list on the GOG Galaxy client right click War for the Overworld
  2. From the manage installation tab select "Configure installation"
  3. In the beta channels drop down select "Unity Engine 5.4.6 (WFTO 2.0.7f1)"
  4. Click OK, your game should then update to the correct version.

Let me know how you get on and if this temporarily solves your issue. I'd also love to get a hold of the crash log from you Posting Output Logs


Cheers,

Lee