Unable to click game objects / tag tiles

  • Views 4,991
  • updated
  • Backlog

OS: Catalina 10.15.7 (19H2)


6-Core Intel Core i5

Intel UHD Graphics 630 1536 МБ

32 ГБ 2667 MHz DDR4

version 2.0.7f1

I checked the integrity of the game files, everything was ok. after several reboots of the game, the bug disappeared. the menu items worked fine. when there was a bug, there was a pickaxe in my hand (cursor), as if I had pointed the pointer at a wall that could be destroyed, and it was not removed either in the main menu or in the game. tried launching different levels of the company - it didn't help. due to a bug, it was impossible to move the camera (it was possible by clicking on the mini-map) and how to interact with the map in any way - select creatures, dig walls.

Game Version:
Steam Public
Lee "Noontide" Moon Designer & Community Manager
  • Backlog

Hi Александр

Apologies for the delay in my response, it's been a busy month.

I'm sorry to hear that you've experienced this issue, I've seen similar reports for issues like this on Windows though they were resolved a long time ago with various updates to the UI Middleware. Essentially my understanding of this issue is that some GPUs incorrectly render the UI Overlay which prevents the clickthrough to the game from properly occurring. This is the first time I've seen the issue described for an OS X system however.

Intel GPUs are most commonly affected of these and are not as widely supported by Unity's rendering pipeline. In the past I would have suggested Unable to click game objects / tag tiles [Fixed in v2.0] as a solution but as this typically requires running the game in an older version of Direct3D this would, to my knowledge, not work on OS X which uses OpenGL.

Unfortunately at this time our team is completely tied up in work on future projects and it will be some time until we can come back around to fully investigate this issue. It may be one in a series of continuing deviation on Apple's side which has caused several of their systems to become unsupported for WFTO over the years, as detailed here. System Requirements

For now I'd like to get my hands on your player.log (How to: Submit a Bug Ticket) to see if there's anything which stands out. But other than that I don't think there's much chance of a timely solution and I would recommend chasing Steam for a refund if you can, with our blessing.

Kind Regards,