0
Completed - Resolved

Mutators not saved in save games.

aediin 2 years ago updated by Lee "Noontide" Moon (Designer & Community Manager) 2 years ago 3

Hello. I am having the following issue: Whenever I'm playing a My Pet Dungeon game with Mutators and God Mode activated, if I save the game, and later try to continue, the game will load the level but without the Mutators or God Mode anymore, and I have no way to re-activate them. This means that custom levels designed to be played with Mutators cannot be continued from a save file. Is there a way to fix this?

Game Version:
Steam Public
Platform:
Windows
GOOD, I'M SATISFIED
Satisfaction mark by aediin 2 years ago
Cannot Replicate

Hi Aediin,

Thanks for the report and apologies for the delay in our response. It's very busy times at Brightrock and in cadence with certain milestones and sometimes it can take a little longer to get around to responding to reports here.

I wanted to let you know that I jumped into My Pet Dungeon today to run this through a test a few times on a few different MPD levels and I couldn't replicate the behaviour you described. Following a save and a load from several MPD levels the mutator set and God Mode settings persisted into the new load.

Unfortunately without being able to replicate the issue I won't be able to push it into our backlog. If you know of any additional steps required please let me know.

Cheers,

Lee

Thank you very much for your reply. I kept doing more tests myself and I believe that this issue, which occurred in the custom My Pet Dungeon map I was making, had something to do with the “Force Enable Mutators” and “Disable Player Mutators” settings both being checked. My map now doesn’t have either of those and I no longer experience the reported bug. Everything is working perfectly now. Thank you very much for your time and attention!