0
Marked for Review

The map is completely broken.

Windows 10 64 bit, 8 Gm RAM, Intel(R) Core(TM) I7-4500 CPU1.80 GHz 2.40GHz GPU: AMD Radeon R7 M265, Intel(R) HD Graphics Family. v2.0.7f1

I made my first map using MS, applied a lot of scripts (they worked earlier, I doubt it was them). I will be sadly, if this map published in Steam, which has subscribers, will remain useless.
The problems is only with this map, I checked on other people's map, and also did mine map in the same mode (custom).
The problems are global -the Esc button doesn't work (so I either have to finish the map - i.e. I win/loss, or kill the game through the task manager), most tiles can't be captured (not only I can't captured, but also AI), outposts don't capture tiles, "replacement earth" doesn't turn into earth. In npcdebug mode I looked and didn't see Empire (although its core is there and its identity is specified). Almost all the tiles under the rooms I captured with the spell "Annex", it worked. The workers, including ghost workers, could not reinforce the walls. There were other buggies.
Another oddity. After I found the problem (it came after I published the map in Steam), every time I edited the corrupted map and played it and then quit the game - every time after this, I checked "Verify integrity of game files" in Steam, the files were replaced (almost always 2, in one case 1 file).

Watch the video
.

Map Seven bridges of Königsberg - there's another player's comment. same problems.
Maybe the problem is with the letter ö in the name of the map, but I doubt I've ever made a map with a similar name (the word Bridge was capitalized there) and published "for friends" in Steam, there was no such problems.

Map files (in D:\Program Files (x86)\Steam\userdata\88441177\230190\remote ): Map Seven bridges of Königsberg.rar
Please fix my map, so that I can change it in Steam.


Game Version:
Steam Public
Platform:
Windows

I made a copy of the map (imported), Seven bridges of Koenigsberg - there are the same bugs.

I found out the reason for the bug. I made another map, and there was this script: the trigger was "On Start", the action was "Modify AI (Personality - Guardian Personality, difficulty - dominant, faction - Empire"). Look at this screenshot.

At the same time, in the settings of the map, I indicated the Empire's personality (complexity - dominant, and personality - Mira). I also added a screenshot.

In that map I added 2 more triggers, but they do not matter for the bug.

I removed the trigger with the action "Modify AI", saved and republished the map. And the bug is gone!

I removed a similar Trigger in the map "Seven bridges of Königsberg" (the Trigger also touched the Empire, and in the settings of the map I also set an Personality for the Empire) - the bugs are gone too. That is, the problem with this trigger (On start - Modify AI).

And, let me explain to you, I applied the Modify AI action, because the Empire personality settings in the map were not applied (I looked when I played, through npcdebug - Empire had no personality (although something sluggishly built). Both maps are of the "Custom" type.

This is another bug (consisting in the fact that the indication of personality for the Empire does not work).

I made a script where the trigger is the Empire blade lotus damage. And the action - "Modify AI" for the Empire (in the line "Personality" this time just specified Ravager, instead of "Personality Ravager"). There were no bugs this time, and the trigger to change the Empire's personality worked. So I have two versions of the reason for the bug.

1) Conflict of "On Start" trigger with "Modify AI" action (at least for Empire, if Empire Personality is specified in card settings).

2) Wrong value in the "Modify AI" line (in the "Personality" line) - i.e. I've specified something, that MS (Mighty Script) can't process, the map is broken.

In case 2), MS should a) indicate that an invalid value has been entered, and b) suggest variants of the appropriate value.

And even more correctly and conveniently it will be possible to make a drop-down list instead of a text string, in this case it will be impossible to enter the wrong value - the map creator will only have to choose Personality.