0
Not a Bug

ID error in Mighty Script's "In Area" condition

Black Emperor 1 year ago updated by Cian Noonan (Graphics Plumber) 1 year ago 2

Hi,

I've come across what I think is another bug in the Map Editor. I was building a new map (custom type) and tried to replicate the campaigns' home realm mechanics with the clickable blocks that would generate money or spawn hero parties. For that I used a script with an "On Click" trigger and an "In Area" condition. In the latter, I used the world picker to pick the blocks I would want the player to click in order to do these things and they show up correctly in the list. However, when attempting to test the map, Mighty Script always gives me "Some IDs don't exist anymore" errors in all "In Area" conditions.
I also tried to reveal map areas on start, also using "In Area" conditions, but this time I chose the area center and radius instead. Same problem here, ID errors would show up when testing the map.

Game Version:
Steam Public
Platform:
Windows

Okay, using both "To check" and "Area Centre" with a radius greater than 0 seems to eliminate the bug, I thought you had to use either but not both.
I've noticed that it doesn't really do what I inteded though. But that's not a bug anymore, I'll have to figure out something else.
Well, I guess I've solved it myself then, sorry for the trouble!

EDIT: Adding "Is of type" seems to do the trick.

Not a Bug

Glad to hear that you got it working