0
Completed - Resolved

Black Screen on Launch 2.0.5

Ml Fx 1 year ago updated by Cian Noonan (Graphics Plumber) 1 year ago 7 1 duplicate

Hi, I installed the game after version 2.0.5 released.
The game launches, but the screen is black, and nothing happens.
I think I have all required libraries installed.

I also checked the logfile /home/USER/.config/unity3d/Subterranean Games/War For The Overworld/Player.log

I would see more debug messages, which can help me to find out what the problem is, but i don't know how to activate the debug output.


  • linux
  • Arch Linux
  • 64bit
    • 16GB RAM
    • Intel(R) Core(TM) i7-4770K CPU @ 3.50GHz
    • Nvidia GeForce GTX 960
  • game should be 2.0.5 (fresh install)



Logfile:

Player.log

Game Version:
Steam Public
Platform:
Linux

Duplicates 1

same for me, I can access the ingame steam overlay tho (the shift + TAB menu)

Marked for Review

Hi Cat Cheshire,


Thanks for submitting your report here. It seems this is an issue that is affecting other Linux users. I will be merging your ticket with another ticket to put everything in one place.


Once we're back in the office tomorrow morning we'll investigate.


Sorry for the inconvenience!

Marked for Review

Hi Folks,


Sorry to hear you're having this problem. We've had a few reports come in regarding this now and it seems something has gone wrong with the build on Linux.


Thanks for submitting the report here, we will be investigating first thing in the morning.


In the meantime please could you confirm that you have the additional requirements listed under the Linux section in System Requirements. The issue seems very similar to an issue we had previously where a key dependency for our UI Middleware was missing, as this has been updated in this patch this might be an explanation.


Once you've confirmed whether looking into any of those has an affect for you and if you're still not able to get into the game then I've move v2.0.4 onto the Previous Build Branch on Steam so you can opt into that in the meantime and play the previous version until we can investigate further.


Deeply sorry for the inconvenience.


Lee

I've rolled back the default branch to v2.0.4 for now as we're not quite sure how wide spread this is. The issue didn't show up on our tests but we want don't want to leave a potentially faulty build out by default. So you should be able to opt back into the Default branch and get 2.0.4 now. If you still want to try v2.0.5 it is now on a Linux Beta branch.

Sorry once again we'll take a deeper look tomorrow.

Pending Customer

We've redeployed a modified version of v2.0.5 for Linux to the live branch. This should not be affected by the black screen issue.

Please note that this build does not include the UI Middleware update as we believe it is an incompatibility between the latest version of the middleware and some Linuux distros which is the root cause of the issue.

Please let us know if you have any problems with this new release. We'll keep monitoring the situation from our end and reach out to the middleware provider for Linux support.

Thanks for fast fixing the problem. Now the game is startting under linux well.