0
Completed - Resolved

Stuck inside possession, esc or space don't exit.

Johny 1 year ago updated by Lee "Noontide" Moon (Designer & Community Manager) 1 year ago 9

I've been playing the Heart of Gold campaign and in the last two maps of the campaign I've encountered a bug that made me unable to leave the possession of a unit. In the last map, I've been possessing the Colossus with no problem in order to destroy the inhibitors, but for some reason (I can't seem to find out what the trigger is) at some point I become unable to leave the possession and in this case my last auto-save was while in possession. When this bug happens all I can do is alt+f4 or terminate the game process, because other inputs unrelated to possession, such as quick-load or quick-save, do not seem to do anything. The possessed unit can still be used to move around/attack etc.


When I try to load this auto-save, I'm not in possession anymore, but sometimes I can't use any spells or hotkeys, though the menu will still work; and if I load this auto-save and I try to make a separate save, the game simply crashes. Unfortunately, the first time I tried saving over my previous save, and that save got corrupted and removed.


I tried to look for a crash log, but I am unable to find one. I can try to make a video of this happening, if that's helpful.


It's quite frustrating to lose so much progress in this large map just over a bug with possession which I haven't seen mentioned, and I suppose I will just avoid possession altogether to do the map now, but it was really handy.

Game Version:
Steam Public
Platform:
Windows
GOOD, I'M SATISFIED
Satisfaction mark by Johny 1 year ago
Pending Customer

Hey notrop,


Could you please send the broken save file and if you have it, an output_log from a session where this was an issue.


Posting Output Logs

How to: Locate your save files

Hi there, I can't give you the output log because it has been cleared since the problematic sessions, but when it happens again I will make a copy of the log for that session and add it here asap.


The original save file I tried saving over that got corrupted seems to have vanished completely, as I can't see that save in the folder either. I'm including the last autosave which occurred during the possession and started to cause the crashing/bad saving issues.  wtfo_hog4_auto.zip

I loaded the auto-save and possessed the colossus again and tried to exit the possession and it didn't work; And I used it to punch Aetna(the daughter of the duke?) and it caused the game to freeze.


Here's the log: wfto_hog4crash_output_log.txt

Accepted

There's quite a lot wrong here, we'll see if we can sort this all out.

I have a separate but related incident regarding this; I have started the HoG 4th map from scratch and got up to about 50mins and then stopped after an auto-save which worked fine. This auto-save was made during a dialogue from Loa and a single dialogue line is spoken as soon as the save is loaded, but after this, a number of things start to go wrong; saving or auto-saving cause freezing, though oddly, the music keeps playing instead of stopping - in addition, if you carry on without saving, Mendechaus no longer speaks about alerts (which show up on the right-hand side of the screen).


Here's a log: wfto_hog4_savefreeze_output_log.txt

Here's the auto-save from which it happens: wfto_hog4_autosave_2ndproblem.zip


I have seen old old topics about RAM being related to freezing/crashes, but while I don't think this is an issue as I have 16gb of ram, the game does always seem to get stuck at 3.9gb and 7-9% cpu when these freezes occur. I don't know if this is helpful.


I do hope you can find out what's causing this, and I hope it's not a common issue, because it's just turned this campaign map into a chore, sadly. Thanks for the quick attention to the reports, it's really the first time I've ever had a real issue with the game.

Completed - Next Patch