Completed - Resolved

Map Editor: Maps set to legacy after 2.0; then when changing to the proper format, they report an error when trying to test

journeywithin 5 years ago updated by Lee "Noontide" Moon (Designer & Community Manager) 5 years ago 9

Not sure if this effects all maps but I experienced it with a MPD map I have been making.  The map was set to MPD about a week ago when I first created.  Today (Saturday, May 5), when I went to test it, it told me mightyscript wasn't allowed.  I verified the map settings and the map was set to Legacy.  So I changed it to MPD.  When I tried to test it, it said that key features were missing (ie. heart, toybox, etc).  I deleted the toybox switch/gateway and player1's heart, then replaced these items.  When I went to test again, it said mightyscript isn't allowed... and the game mode was reset to Legacy.

Game Version:
Steam Public
Pending Customer

Could you please upload your map files and your output_log.txt from a session where you tried this

How to: Locate your save files

Posting Output Logs


my pet dungeon shadow realm_edit_76561197993291628

Loaded the map; went to map settings; it is set to legacy; clicked that and changed to MPD; says there are errors/missing objects; I delete the toybox/gateway and resize the toybox to 5x5, then put toybox/gateway back in; I delete player1 heart and put back in; I delete some other empire props and put back in; export/test = "errors in map"; save+quit; load map again; it is set back to legacy.

I'm sorry but we're missing the associated .meta file , could you add it as well please please ?

Marked for Review

I'm assigning this back to review so we can look at it now we have the Meta. :)

Completed - Next Patch