Firebreather and Inquisitor recipes broken (Seemingly).

  • updated
  • Completed - Resolved

Dear Brightrock,

I am an avid player of War For The Overworld and I love your new Sacrifice Ritual, having been able to summon virtually any unit in the game, albeit for the above exceptions.

I am not sure what the recipes are myself, because I got it from a Steam Community Guide, but I tried them, and they didn't work. Here's the guide since anyone can see it:

Anyway, I tried the following recipes:

Firebreather = Warden + Templar + Rat.

Inquisitor = Beastmaster + Angry Monk + Rat.

Both failed when I tried them in Skirmish Mode and in Map Editor (Testing) Mode.

I have already tried verifying my Steam files, as per the Steam Discussions suggestion, but again, the recipes didn't work. I have also tried deleting and reinstalling the game. The only thing I haven't tried so far is a clean reinstall, but I'm not sure how to do that.

If the above recipes are correct, should they spawn the unit I want, or are these wrong?

And if they are correct, I would appreciate it if you could investigate this issue.

Kind regards,



Windows 8.1 64-bit


Intel Core i7-4790K @ 4.00GHz

NVIDIA GeForce GTX 980

Game version: v2.0f9

Maps played:

Triad (3-Player Deathmatch)

Hollow (Sandbox)

A test map I made to test various Sacrifice Ritual combinations, including the above.

Game Version:
Steam Public

How would you rate the customer service you received?

Satisfaction mark by yueenode 6 years ago

Took time to get a response, but it was worth it.

Add a comment about quality of support you received (optional):


I forgot to include a video and my last output log. I hope you find these useful.

Failed Sacrifice

Output log

  • Under Review
Josh Bishop Creative Director
  • Declined

Declined? But this is an actual bug. The other bug reports above confirm it's a typo in the game data. If in doubt, the community guide has this comment:

"@Yueenode There are two typos in the data resulting in the Inquisitor and Firebreather not working:

In the Firebreather recipe the first warden is specified as 'Warden ', notice the two trailing spaces.
In the Inquisitor recipe the Beastmaster is specified as 'Beastmaster', the actual ingame name is 'BeastMaster'.
All recipes using 'Beastmaster' should not work.

Lastly if you start a recipe with a unit that isn't used as the first unit in any recipes (like 'Beastmaster') you can't match another recipe again until you restart the game."

  • Completed - Next Patch

That was likely an admin error, this should be fixed next patch


Great to hear! Thanks!

Lee "Noontide" Moon
  • Completed - Resolved