0
Completed - Released

Update Loop (*jp.otf corrupt/missing files)

Pete 1 year ago • updated by Cian Noonan (Development Support Engineer) 1 year ago 4

Hi again,


I have an issue with a game update stuck in a loop for War for the Overworld.

Perhaps related to: https://brightrockgames.userecho.com/communities/1/topics/4052-the-game-will-no-longer-runmissing-file (the 1 file that is missing/unreadable that cannot be reacquired).

This has been happening since the latest patch update (since this morning, 0800 BST).

The 1.8gb of data is downloaded, after this - it will install, then validate, then install, then validate, then install, then validate and will not ever complete.


There is only disk activity shown, no download. It is lagging my machine a little despite being on a different drive to my work and system software.

Game validation returns 100% from Steam library.

Found a quick way to determine the "corrupt/missing" files - to click "play game" and "launch when ready" - it has a pop-up window that says:


An error occourred whie updating War for the Overworld (corrupt content files) :

D:\SteamLibrary\steamapps\common\War For The Overworld\WFTOGame_Data\uiresources\wftoUI\common\fonts\NotoSerifCJKjp.otf


So - it appears a japanese open-type font file is corrupt.


However, the otf file does not exist in that directory...There are no other language files present in this directory.


Renaming the \Fonts folder to \Fonts1 appears to have forced the update to redownload the 1.8gb and hopefully this will result in normal install and validation of files once complete.

If this does not work - will escalate to Brightrock bugtracker.

---


While the update was successfully redownloaded and installed, it has returned to the install/validate loop - the error with the same non-existent file.


Game file validation, again, suggests 100% fine.


∴ requring escalation to UserEcho.


Have paused update until solution - appears non-required/missing file is in some validation table but not included in steam validation, perhaps.

May be more simple to ensure that all localisation files are included in download than to fix CRC.

// sighs.

Game Version:
Steam Public
Platform:
Windows

I will attempt to locate the missing file and place it in the UI/Fonts directory.

https://www.google.com/get/noto/help/cjk/

(seven files at 2mb+ !! All other fonts are ~200kb .ttf/.[w]off/.svg - no .ttf)

/* I did notice that the entire Fonts directory was empty after the redownload and reinstall, after forcing this.
Have copied backup contents and entire font family of Notoserif, renaming a copy of "regular" as the missing file */

// Doing this has forced another redownload of the 1.8gb update.

Spoofing the missing *cjkjp.otf file appears to have worked in getting past that. Therefore, might assume that a blank text file name the same would work.

However - there is a new Steam - Error, as the install/validate/install/validate loop resumes.

This time it is:

WFTOGame_Data\resources.assets.resS

This file does not exist.

The folder contents jumps as Steam completes installation and validation - sometimes displaying the full list of files that "used to be" (ie, game levels, settings managerassets, globalassets, etc...) and sometimes only app.info, level0, output_log.txt.

----

It would appear that the library validation believes all files are there (from before this patch), but the new patch has some issues with either missing files or perhaps some typo's and a different validatation/crc to what Steam expects.

Will create this new missing file as a blank text to see if it is required or not.

// That doesn't work - there is an issue with the new update on Steam missing files or perhaps a few typo.resS

// The game will not start, a forced download will not install the missing files (even if game is uninstalled).

----

So far, it appears as if there is an issue with:

* A missing font file for localisation not required for En.
* resources.assets.resS having the additional extension, or the capitalised .resS, perhaps.

Past this, I cannot look, as the resources.assets[.res(S)] appears critical to successful install (cannot be spoofed).

The log files on this machine were last updated in 2016... Despite having run the game since then (I think though, only from a laptop and not this machine while I was abroad - I will not test update on the laptop, because I do not want to break the game for if I must travel :P).

// There is nothing further I can do right now - over to you guys ;)

Fixed it.

The issue was that the disk upon which WftO was installed only had 3gb space - freeing this up to 10gb allowed the package to correctly install.

Idk why I didn't notice that earlier, that there was not enough space to unpack... the "flicking" folder content ought to have been a good indicator. That was dumb of me...

I've suggested to Steam to include a warning that this is the case, as the only indication is the "installing/verifying" loop:
https://steamcommunity.com/discussions/forum/10/1696045708647388052/

Well, that was an hour well wasted :p
Hopefully if anyone else encounters this issue they can come across the solution in Steam forums or here, through google, so not deleting.
(Not that many people search before posting...)

***Please consider this "bug" closed - it was user error, and I feel like a right twonk.***


It was merely that the install required more than double the free space on disck than the download, for it to unpack and correctly install.

(the strange thing is, the game did not download at any point the .otf nor the .resS file when the free space on disk was there - there was only 4mb of data missing and the game is running fine without the *jp.otf and .resS file...)

// it appears the DLC heart of gold and undergames are both missing from the game, but appear in the DLC list in steam.

Completed - Released

Glad to hear that you've managed to solve the issue