0
Completed - Resolved

2.0f1 fails to start on Linux.

Robert Zenz 1 year ago • updated by Cian Noonan (Development Support Engineer) 1 year ago 8

2.0f1 fails to start on my Linux system, 1.6 (or whatever was the previous version, not sure) worked without a problem. Other games work also. I posted this previously on the GOG forum and was redirected here.


From the logs, it seems like that a different GLIBC version is required than I have available on my system. The log is attached. But from what I can gather, libstdc++ is required in the version 3.4.20, however, only 3.4.19 seems to be available through the package manager.


System Information

  • Ubuntu 14.04 64bit
  • 12GiB RAM (DDR3-1066)
  • Intel Core i5
  • nVidia 1050 Ti with 384.111

Player.log


Game Version:
GOG DRM-Free
Platform:
Linux
Pending Customer

Hey Robert,


Could you try to install the latest version and try again?

Where do I get the latest version? GOG only offers 2.0f1.

Sorry looks like the last GOG drmfree build failed. There should be a new one up later today

I'm unable to test it until the mid of the next week, but will try it and report back. Thanks.

2.0f4 still fails with the same error message in the log.


Couldn't open /home/robert/games/war-for-the-overworld/game/WFTOGame_Data/Plugins/x86_64/libCoherentUIGT_Native.so, error: /usr/lib/x86_64-linux-gnu/libstdc++.so.6: version `GLIBCXX_3.4.20' not found (required by /home/robert/games/war-for-the-overworld/game/WFTOGame_Data/Plugins/x86_64/libCoherentUIGT_Native.so)


Could it be that 14.04 isn't supported anymore by the Unity version you are using?

We have updated our UI framework, the requirements for Linux are now 


  • Generally any distribution similar to Ubuntu 12.04 LTS.
  • glibc 2.14 or later
  • libstdc++6 or later
  • GCC 4.8 or later
  • Only 64 architectures are supported on Linux.Only the latest video card drivers are supported.
  • OpenGL 3.0 support is required.

So 14.04 should work


Looks like this is a generic Linux error. a user on stack overflow recommends a fix here: https://askubuntu.com/questions/575505/glibcxx-3-4-20-not-found-how-to-fix-this-error


Try the steps there and let us know how you go

Thanks for looking into this. Thing is, my system does meet these requirements. It looks more like that these need to be more specific when it comes to the libstdc++6 requirement, because I've got 4.8 but from what I can gather 4.9 is required, which seems to mean that GCC 4.8 is wrong there, it actually should be 4.9 as a minimum requirement. You don't get GCC 4.9 on 14.04 without any external PPAs (in short, the need to install libraries build by a third-party), though. Looks like that the build environment is simply "too new" here and does not correctly build the packages for 14.04. Whether that is your problem or that of Unity, I cannot tell.


Yes, I can add a PPA to get newer libraries, I'm also considering upgrading to 16.04, both would solve this issue without problems I guess. But it seems like that there is something fishy in the build environment.

Completed - Resolved

Unfortunately these requirements are given by our 3rd party UI middleware. We will make sure that our requirements better reflect this