Memory leaks - possibly page file corruption?

  • updated
  • Completed - Resolved

Yesterday, I encountered excessive memory leaks during and after playing War for the overworld, map 12 of the main campaign, for around an hour without succeeding.

These manifested themselves into the game lagging out in bursts to load an event or, say, a rally flag being placed. 

However, after quitting out of the game, I found I saw these effects on general PC use. Processes would take forever to load, network activity would slow down to a crawl, even shutting down the PC took longer.

I have seen this issue happen once before, on my PC, in the game Guns of Icarus, which had (and likely still has) an issue with rendering assets on high anti-aliasing settings, leading up to the point where the game would take forever to perform any given action. Exiting the game without rebooting the PC would result in being unable to work properly until that reboot was done. I had this investigated by said dev team, and it turned out to be memory leaking into pagefile, which didn't clear properly after the game closed. Likely, this has happened here as well.

On your request through the community hub, I have tried to replicate this issue, unfortunately to no avail. However, I have included everything necessary including dxdiag before, during and after, perfmon before and during, save file and output log, all from my recent attempt at level 12 (I did clear the level this time, perhaps this has something to do with it? Quitting out?), in the hopes that you might be able to find something. Should I come across the issue again, I will update the ticket if necessary.

WFTO Memleak TS.rar

Also, a screenshot of task manager, after the game has been closed. I could not replicate the issue here, so this is likely useless, but here you go.

Perfmon RAM after.png

Game Version:
Steam Public
Duplicates 1
Memory Leak

This is on HoG level 3 after about 2 hours. After beating the level, the game still kept the memory allocated. When I tried to reload an autosave from the level, the game crashed with a memory error.

This happens across multiple levels/maps. I hope it is fixed in 2.0!

Also I have 16gb of mem, so it isn't a issue for now :P

Other stuff:

- I notice that sometimes particles/effects aren't deleted, such as bombard cannon balls get 'stuck', spell effects sometimes remain, minion effects sometimes remain.  (Clearly issues with the memory leak since these resources aren't being deleted/freed)  I can take a screenshot the next time I see it if it helps.

- I play at max camera zoom if that helps.

- On other maps that I typically encounter issues are large (ie. HoG 3 is large; normal campaign later maps that are big; scenarios that are big).

- Windows gives me a "close this program due to memory issues" warning (which can be accepted or ignored).  I ignore the warning because I still have a lot of memory left (4gb+ usually).


Win7 x64; 16gb ram; radeon rx470; intel i7 4core

  • Under Review

Hey we are looking into this, we'll get back to you once we know more

  • Completed - Next Patch

Could you please verify if this is still an issue after the next patch

Lee "Noontide" Moon
  • Completed - Resolved