0
Completed - Resolved

object reference not set to an instance or object error while loading an save

Richard Splinter 2 years ago updated by Mendechaus_Cultist 1 year ago 10 1 duplicate

Hi!


Im getting consistently an error while loading this supplied save, wich is from level2 of the Heart of Gold expansion. The error is "Object reference not set to an instance or object"


dlc1_campaign_level2_name_20180123195203dlc1_campaign_level2_name_20180123195203.meta


When I use an earlier save, it works like this one:


dlc1_campaign_level2_name_20180121234941 dlc1_campaign_level2_name_20180121234941.meta


but the problem is, when I play from that point, and save again, that save will also produce the same error. I tried different approaches to determine what causes the error, I dont have anything in my hand. I just killed that named Crackpot.  But in the end it still produces the same error.


Outputlog:

output_log.txt


no crash log found.


running this on Windows10, i5 4570, 8 Gb ram, wd blue 1 Tb HD, MSI gtx 970 4 Gb


Cheers!

Richard


Game Version:
Platform:
GOOD, I'M SATISFIED

awesome support for an awesome product, will pick up the new expac soon!


Satisfaction mark by Richard Splinter 1 year ago

Duplicates 1

Under Review

Hey Mateusz,

Thanks for the report, we will look for the root cause and keep you posted on our progress

Under Review

Hi Richard,


Thanks for reporting this to us, I'll move this report to the bug tracker for our QA analyst to review.


Cheers,


Lee

Pending Customer

Hey Richard,


I've loaded the first file and can confirm that there is a corrupt block in the file that is preventing load. This file is unfortunately unrecoverable. I'm not able to replicate this issue unfortunately. Can you talk me through exactly what you're doing before you made the second save?

Hi!


Okay I think I found the problem, it has to do with the Artefacts. If you load the working save in my first post, you see I still have one Artefact ready to be activated. If you activate that artefact, and then save it, that save will produce the error,


the weird thing is that I cant remember when I received that artefact, I didnt have claimed that much shrines in that part of the game.


cheers,

Richard


Accepted

Cheers for the detailed repro, sounds like it should be a simple fix


edit: nevermind just activated an artefact from a shrine I claimed, and it still gave the error. so it can be any artefact to deliver the error. Im going to restart the mission, see if its reproducable from that.




cheers,

Richard

Completed - Next Patch

Hi, I have exactly the same critical error in the main campaign at level 12 and level 13 when I try to load a savefile after I have saved the gane. The message is: "Object reference not set to an instance of an object"


After the bug, the game is going back to the main menue of the game, but has no more sound. After a restart of the game, the sound is back, but the error with the save files is still there.


I never had before such a bug and my system is fine, so it would be great if the brightrockgames-team could fix the bug in the near future. Thank you very much for your help.


Greetings,

Eric


My system informations are:


Windows 7

Intel(R) Core(TM) i7-2600 CPU @ 3,40GHz 3,40 GHz

RAM 8,00 GB

64 bit