0
Not Fixable

Map editor broke

Webbernever1 2 years ago • updated by Cian Noonan (Graphics Plumber) 2 years ago 2

This is not the same as the issue found here:

http://brightrockgames.userecho.com/topics/2540-map-creation-frozen/


I am not entirely sure what happened but I suspect the memory bug may have had something to do with this. Effectively, I had just mirrored, saved, and published a map to friends, and the map editor started acting fairly strange. The editor, itself, still worked but the arrow keys no longer functioned. Whenever I tried to place a tile, it would transform all adjacent tiles of the same type to the tile in question. For instance, if I wished to make a dirt tile into a rocky tile, it would transform all dirt tiles, not just the one I had selected. I exited it shortly after, I probably should have taken a screenshot or two but I managed to forget.


A couple of theories:


1 - I was using a map which was 100x100, hence fairly big, and which almost exclusively featured multiple coloured tiles. Hence, it is very likely that this amplified the memory bug.

2 - I had a couple of instances before where the map editor acted strangely, it may be due to mirroring from a corner. A quick setup I once used which caused problems was:

Step 1 - Create a two-player map with equal length/width. I presume that this occurs more on larger maps, so try a 126x126.

Step 2 - Place One dungeon core, such as the green one, in one of the corners. Surround it with fortified walls so that you can see what happens more clearly.

Step 3 - Use the corner mirroring tile. If it works, you should end up with one green dungeon core and two blue dungeon cores, one of which the game does not recognise.


I have no idea if this is the same issue but I suggest that the mirroring tile may be the source of these problems.


Output log:

output_log.txt

Game Version:
Steam Public
Platform:
Windows

A couple of screenshots of the dungeon core bug mentioned in point two. I am presuming that these two issues are linked.






Not Fixable

Hey webbernever,


The first issue you are describing sounds like what happens when you hold control and place a tile, it may have been that your control key was stuck or that the game bugged and thought that control was always down.


The issue with the mirroring isn't likely to be fixed as the player can simply delete and replace the dungeon core. I know this isn't ideal but the mirroring tool tends to have these quirks, and the time we would spend to fix this would be huge compared to the time saved by the user from no longer having to replace the cores.


We are planning on changing a lot of the map editors functions with 2.0, doing so may iron out issues like this, but until then you'll just have to work around it.