Not Fixable

game unable to load first map (OSX)

ngmatt8652 5 years ago updated by anonymous 5 years ago 9

After watching the cutscene on the first map of the main campaign the bar will get 5/6th of the way full before stoping, this is accompanied by what sounds like a metallic thumping. All steps on general crash troubleshooting have been tried, none have fixed the issue. (CoherentUI_Host crashes at game launch, may or may not be related)

running OSX 10.9.5 64 bit

processor 2.7 GHz Intel core i5

memory 12 GB 1333 MHz DDR3

Graphics  AMD Radeon HD 6770M 512 MB

posting output log Player.log

Game Version:
Steam Public
Pending Customer

Hey Matt,

It looks like a core dll file from the game is missing, could you please verify that GalaxyCSharpGlue.dll is in the games plugin folder in the applicationcontents/WFTO_GameData/plugins

The file is not in the plugins folder and repeating verify integrity of game files dose not make it appear.

I've attached the missing file, please try to download and place this in your installs plugin folder.


This has unfortunately not fixed the problem however the folder application contents dose not exist so I assume you meant the application support folder so the folder path I used was Users/(username)/Library/Application Support/Steam/SteamApps/common/War For The Overworld/WTFO.app/Contents/Plugins

Ah sorry, if you rightclick on an app in the app folder you get to it's "Contents", that's what I was referring to. My macOS lingo isn't very good.

In that case it is likely the entire install is buggered, have you tried reinstalling yet? I'm also going to run our mac machine through it's paces and see if I can reproduce the issue.

reattempting the reinstall did not work nor did repeating putting in the dll file, I am out of ideas myself so I a going to need to wait for anything on your end

Sorry, it looks like I might have sent you to the wrong folder, could you try to put the file in: Contents\Frameworks\MonoEmbedRuntime\osx

If that still doesn't work we will explore another way to get the game to you.

I also have to warn you that your GPU is below minimum spec, we require 1500 points in the PassMark benchmark, you can see http://www.videocardbenchmark.net/gpu.php?gpu=Radeon+HD+6770M&id=285 that your card averages about 992 points, more than 500 points below the minimum. You can try to play the game, but we cannot guarantee that it will work on later levels.

Apologies for the week long delay, no putting the file there did not help I am at a loss for what might be happening but as for my GPU I do have workarounds for that.

Not Fixable

Honestly I don't know what to suggest, we can get the game running on our mac test suite and other mac users are able to play just fine. If you could attempt to do a full reinstall that may help but I'm at a loss as to the cause...