0
Completed - Resolved

Skirmish Loading, or lack of.

Th3_}{o0d 2 years ago updated by Lee "Noontide" Moon (Designer & Community Manager) 2 years ago 9

Win 10 64
9370 FX
16gb Corsair vengeance pro 1866
R9 290x 
Game Build: 1.6.2F3 
output.log 
Unable to load any Skirmish map, no saves accept campaign progress. On clicking start game under Skirmish sub menu's, loading progress with instantly jump to 30% then 40-45% a second later. Moves no more after that regardless of time left.

Things I've tried.
Verifying files
Complete uninstall, along with complete folder and file removal.
Ran with admin elevation.
Unplugged USB headset (something I read about a near identical issue back in 2015)
Reset sockets. (Again from old issue in 2015, thought nothing was flagged in output.log)
Moved files to C:/ (Currently install all games on a 1tb WD black drive, never had an issue before with dir location, was worth a try I guess)


Game Version:
Steam Public
Platform:
Windows
Under Review

Hi Hood, thanks for making a ticket as request

I took a quick look at your log but I can't see anything out of the ordinary in there (but i'm not a coder so they might have more luck). Have you double checked your anti-virus isn't messing with the game in some way, that's the only thing I can think of that you haven't tried already.


I expect Cian will be along at some point (probably tomorrow now since it's 9pm in the UK) to offer a bit more advice/help than I can.

I'm not a prolific coder by any means but logs left me head scratching too.
Tbh I had overlooked AV conflicts, I'll disable and test now. I'm using Avast for clarity.

Same result. *Cries a little*

Pending Customer

Hey Th3_}{o0d,


I'm sorry to hear that you're having issues loading certain parts of the game. The worst part is that the log contains nothing pointing to the cause of the issue.

Someone else was having a similar issue and they seemed to fix it by uninstalling the game and then running CCleaner. When they reinstalled the game they were able to load maps again.


If you could try that and let us know if it fixes it for you that'd be great, otherwise I don't have much more to suggest

I learn't a valuable lesson today, never overlook anything. No matter how trivial it may be. 


So, I did as you advised, uninstalled, ran CCleaner, no joy. So I did a complete clean with CCleaner after another install. Nothing.
I wondered if my MS account was corrupt as I've been having issues with rebuilding my local network (with local domain) and HomeGroup (That I chuck on general shares for the home) So I completely reinstalled Win10 (not from a backup image) Still I was unable to load Skirmish past 45%. 
I figured I'd read the output.log once again just on the off chance it was a different issue. I'm not the best coder in the world, but I can read most langs even if I can't write in them, so most of what I was seeing made sense. Until I saw my username. . . The }{ is made up by curly braces (as I have used on this forum in my user also) But for some reason I read it as unescaped. It was openlined (not encased in denoting '' for a string and not val or var) so I changed my user name (nothing else was changed at this point, literally retried to run WFTO, read output.log, changed name, reload) And VOILA! Complete load and in map in less than 3 seconds. 

Could you please try and reproduce and patch this please, I'm quite attached to my use of the braces, weird I know. But as they aren't escaped, well, I wont say anymore as you'll know the potential this may hold. Feel free to censor and/or delete this post for those reasons.

Completed - Next Patch

Lucky all it broke was a String.format call when we print out the name of the user in the log like so: 1: Player: 'Th3_}{o0d', type: Human, startPos: 2, team: 0, local: False, host: 'True', colorIndex: 6, needsMap:False


We've prevented this issue by not running pre-formatted strings through this call. Expect this change to be in the next hotfix, which will be on Monday at the earliest.

Lucky indeed, I've seen similar parsing issues destroy torny tables :D
Thank you for the assistance, my experience here has been better than most.

I'm glad to hear it, hopefully you can enjoy the rest of the game issue free.