DllNotFoundException: /Plugins/GalaxyCSharpGlue.dll

  • updated
  • Completed - Resolved


I am one of the bakers of WFTO, but I didn't play the game, yet. Two days ago I installed the game on my computer:

  • OS: Windows 10 Professional 64 bit
  • 64/32bit
    • 12 GB Ram
    • Intel Core i7 CPU - 3.07GHz
    • Video: NVIDIA GeForce GTX 960

Game version is v1.6.2f1

The application starts, but when I try to begin a campaign or "My Pet Dungeon" mode; it freezes upon loading, when the load bar is almost complete. The sounds start to be repetitive, and text info at the bottom of the page still changes, but loading never completes.

The output log file grew to 20MB in few minutes; with this single exception message, repeated on and on:

DllNotFoundException: E:/Games/Steam/steamapps/common/War For The Overworld/WFTOGame_Data/Plugins/GalaxyCSharpGlue.dll
  at (wrapper managed-to-native) Galaxy.Api.GalaxyInstancePINVOKE/SWIGExceptionHelper:SWIGRegisterExceptionCallbacks_GalaxyInstance (Galaxy.Api.GalaxyInstancePINVOKE/SWIGExceptionHelper/ExceptionDelegate,Galaxy.Api.GalaxyInstancePINVOKE/SWIGExceptionHelper/ExceptionDelegate,Galaxy.Api.GalaxyInstancePINVOKE/SWIGExceptionHelper/ExceptionDelegate,Galaxy.Api.GalaxyInstancePINVOKE/SWIGExceptionHelper/ExceptionDelegate,Galaxy.Api.GalaxyInstancePINVOKE/SWIGExceptionHelper/ExceptionDelegate,Galaxy.Api.GalaxyInstancePINVOKE/SWIGExceptionHelper/ExceptionDelegate,Galaxy.Api.GalaxyInstancePINVOKE/SWIGExceptionHelper/ExceptionDelegate,Galaxy.Api.GalaxyInstancePINVOKE/SWIGExceptionHelper/ExceptionDelegate,Galaxy.Api.GalaxyInstancePINVOKE/SWIGExceptionHelper/ExceptionDelegate,Galaxy.Api.GalaxyInstancePINVOKE/SWIGExceptionHelper/ExceptionDelegate,Galaxy.Api.GalaxyInstancePINVOKE/SWIGExceptionHelper/ExceptionDelegate)
  at Galaxy.Api.GalaxyInstancePINVOKE+SWIGExceptionHelper..cctor () [0x00000] in <filename unknown>:0 
Rethrow as TypeInitializationException: An exception was thrown by the type initializer for SWIGExceptionHelper
  at Galaxy.Api.GalaxyInstancePINVOKE..cctor () [0x00000] in <filename unknown>:0 
Rethrow as TypeInitializationException: An exception was thrown by the type initializer for Galaxy.Api.GalaxyInstancePINVOKE
  at Galaxy.Api.GalaxyID..cctor () [0x00000] in <filename unknown>:0 
Rethrow as TypeInitializationException: An exception was thrown by the type initializer for Galaxy.Api.GalaxyID
  at NetworkServer.Update () [0x00000] in <filename unknown>:0 


I used "Verify Integrity of Game Files" feature of Steam client, and it reported "All files successfully validated".

Please help me fix this, because I would really like to finally play (I was a big fun of DK2 and I backed the Kickstarter campaign).

Kind Regards,

Roberto Prevato

Game Version:
Steam Public
[Dev] Nanorock

Hello : ) I'm sorry about the issue you encountered, and I'm really surprised that after a cache and integrity verification from Steam the DLL was still missing.
The Plugins folder should look like this:

In case this file is still missing, You can download it here, and copy it to E:/Games/Steam/steamapps/common/War For The Overworld/WFTOGame_Data/Plugins/


If it doesn't solve your issue please get back to me over here =) 

Cheers !

Roberto Prevato

Hello, Thanks for your quick answer!

I apologize for not giving sooner more insight, but yesterday evening I verified that I do have this DLL in the folder written in log (E:/Games/Steam/steamapps/common/War For The Overworld/WFTOGame_Data/Plugins/GalaxyCSharpGlue.dll); so I think the missing dll is another one, referenced by this assembly.

After some Googling, I found a person who described the same problem, here: https://www.gog.com/forum/offworld_trading_company/game_doesnt_load_the_main_menu

This person claims that he resolved by reinstalling MS Visual C++ 2012 runtime. On my computer I have an almost clean installation of Windows 10 Professional, and I do have MS Visual C++ 2010, 2012 and 2015 runtimes.

Is it possible that I also need to do something about MS Visual C++ 2012 runtime?


As a side note, my Plugins folder looks fine: I have all dlls.


I add a screenshot of my Programs, installed C++ Runtime

Best Regards,


[Dev] Nanorock

Steam (and GOG) are supposed to setup Visual C++ 2012 when installing WFTO :^/ ( We do require it :^] )

So yes, if you can please install or re-install MS Visual C++ 2012 runtime it should solve your problem :)

Tell me when you get a chance to do so, if it solved your problem ^^

Best regards,


Roberto Prevato

Thanks again. 

When I first answered, I mistakenly wrote that I had only 2010 and 2015 runtimes installed, but I didn't see properly yesterday evening. I checked again and I do have 2010, 2012 and 2015 installed (like in above picture).

I will try to reinstall 2012 Runtime and let you know if that fixes the problem. :)

Roberto Prevato

Hi Nano,

I did reinstall Microsoft Visual C++ Redistributable 2012 (both 32 and 64 bits)downloading the files from here:



Unfortunately, it didn't help. Interestingly, the load bar stops always at the same point (about 80 - 85%).

I am pretty sure that other people may experience this problem, because I have a pretty clean installation of Windows 10.

I attach the log, taken from \Steam\steamapps\common\War For The Overworld\WFTOGame_Data\


I will be happy if you have any idea of if you'll find a solution for this.

Best Regards,


[Dev] Nanorock
  • Under Review

Then I'm afraid it is a little bit more complicated than I expected :^/ 

Galaxy dll is a third party software we're using, I will contact them with this information. I'll keep you updated.

Roberto Prevato

Once again, I comment today.

For personal reasons, I installed Visual Studio 2017 on my computer. Among other things, it installed C++ Runtime for 2013; and replaced version 2015 with 2017.

Now my setup looks like this - when it comes to Visual C++

Out of curiosity, I tried again to run WFTO, and it now works! I cannot say whether other things that were installed contributed to resolve the problem, but I would expect that changing C++ would be sufficient.

This is something you should really investigate, in my opinion. In the past I had other situations, in which things started working only after installing VS (for example, the Crypto module for Python, which is also depending on C++).

[Dev] Nanorock
  • Completed - Resolved

Thanks for sharing your finding ! 

I will indeed investigate if we are now requiring VC++ 2010 or 2013.

I'm glad that it now works for you =)