Completed - Resolved

Corrupt update files (Anniversary patch)

Rivia Kallestofeles 6 years ago updated by anonymous 6 years ago 5

Game won't start with the newest anniversary patch.

Tried cleaning offline cache from steam, complete uninstall/reinstall, verifying game files. Result is a corrupt update on Linux.

Image 2862

Game Version:
Steam Public
Satisfaction mark by Rivia Kallestofeles 6 years ago

When I hit the play button, it will start downloading the patch again, then fail, in an infinite loop.

Pending Customer

Hey again Rivia,

First off, thanks for the great review you gave the game few weeks ago, I'm glad to see you got it all working.

As for this patch, it should be about 500MB in size; so your screenshot is pretty confusing. Steam handles all of the distribution so I'm not sure if there is much we can do. I just gave it a quick test on our Ubuntu machine and was able to download and reinstall correctly, so I'm pretty confident that the issue isn't with the Linux copy as a whole.

Have you tried to reinstall Steam? Can you download any other Steam games?

Thanks for the quick reply - as usual, you guys are awesome! :)

The initial patch was indeed under 1GB in size, but as it failed, it started downloading the 2GB version. (I guess it's the core game itself?)

I can download other games just fine, Ark updated as I write this. :D

But I'll try reinstalling the whole steam anyway just to be sure. Will update once that is done.

Oh boy, this is messed up. :D

Well, I found the solution.

After reinstalling Steam and WftO 3 times, I read an article regarding CS:GO having the same issue under Linux and for whatever reason, it didn't like that it was installed on a NTFS partition. So I uninstalled the game and re-installed it under my ext4 root partition and now it works just fine.

I guess it has something to do with how Steam manages the updates and how it sometimes fails to properly upgrade/install on NTFS partitions under Linux. Anyways, rest of the game library is still working fine on NTFS gaming disk, but WftO now enjoys a private location in my home. It ain't pretty, but it works, and that's all I need.

Now I have some dungeons to carve out and another update-review to do for the My Pet Dungeon.

Thank you Cian for the quick reply as always, and send my regards to your team, again! :)

See you in the darkest of dungeons Underlord! >=)>

Completed - Resolved

Fantastic to hear that Rivia, and thanks for posting back, thats a useful insight.

Best of luck carving out your very own pet dungeon Underlord, get out there and claim what is rightfully yours!