0
Completed - Resolved

Game crashes when selecting gampaign

DracS 3 years ago updated by Andrew "Nutter" Jaggar 3 years ago 3

When starting campaign the game crashes after it goes to strategy map, 1-2 seconds the screen flickers and it goes back to desktop. If i put everything low at options i can play the game fine... I have Asus Rog laptop (G752VS) crash.dmp error.log output_log.txt

Game Version:
Steam Public
Platform:
Windows
Pending Customer

Hi DracS thanks for making a bug ticket. I took a quick look at your output log and noticed a repeated error which looks like this:


D3D11: Failed to create RenderTexture (1920 x 1080 fmt 44 aa 4), error 0x887a0005


I'm not one of the coders, but the fact it mentions D3D11 makes me think it might be a DirectX 11 issue. Have you tried forcing the game to run with DX9?


If that doesn't solve the issue then we'll need one of the coders to take a look at the output log and figure out what went wrong (i'm only guessing since I don't know as much as they do), unfrtounately the entire dev team is away for the christmas holidays so it might be a few days before one of them gets chance to take a look.


I've quoted a section from our missing UI knowledge base article which explains the process of forcing the game to use DX9


----------


Case 2: Incorrect rendering mode (DX11 instead of DX9 loaded or vice versa)


If you have tried the above Case 1 solution but that has not worked and you are on a Windows system then you can try forcing WFTO to launch in DX9 mode or DX11 mode. To do this follow these instructions.



  1. Right click the game in your steam library and go to properties
  2. Click "Set launch options"
  3. Add "-force-d3d9" in this box (No quotation marks)
  4. If this fails and you have a DX11 compatible GPU then add "-force-d3d11" instead.
  5. If you are running Windows 10 or newer you can also try "-force-d3d12"

----------


Let me know if that solves your issue, and if not i'll tag the ticket for a coder to take a look once they're back off holiday.

That worked for me "If you are running Windows 10 or newer you can also try "-force-d3d12"

Thx for quick help =)

Completed - Resolved

No problem, have fun playing.


Marking as complete.