0
Completed

MAP 13 CRASH

james.crowell 3 years ago • updated by Lee "Noontide" Moon (Community Manager) 3 years ago 7

Map 13 crashes when I get really far into it. It is not at a set action or time though, and is not tied to the number of minions or progress into enemy territory because I have restarted the mission and proceeded differently and still had the problem.


When it is crashing it drops me to my desktop and generates a little windows error box telling me that the game crashed (I did not think to screenshot it or write the error codes down, but I will update this bug report with that information the next time it happens.) When it crashes like this I am unable to load any saved files that were saved recently (save files from early in the mission are still loadable though.) Trying to load a more current save file results in it crashing and giving a "Microsoft Visual C++ Runtime Error: R6025 - pure virtual function call". I have started the mission from early save files that worked and ended up crashing out and I have started the mission fresh from the map/mission selection screen and had it crash out. Each time it makes any save files that are far into the mission become unloadable.


I have tried with massive numbers of minions and I have tried with a much smaller force (heck, one time my minions hated me and kept rebelling, so my army was very small). I have tried attacking the forge in the north east first and I have tried attacking the crypt in the north west first. The furthest I have gotten before crashing out is reaching the first pink crystal I need to destroy to lower the barrier. The earliest it has crashed on me was during an assault on the forge area.

Game Version:
Steam Public
Platform:
Windows

Please upload your Output_log, when it crashed (if you restarted the game or loaded something else, it get's overwriten, then there's no ned for it).


Did you got an Crash log?

https://brightrockgames.userecho.com/topics/118-how-to-submit-a-bug-ticket/

You probably won't need to replay the 3 hours for a new crash report, this one should do fine.


In the meantime, this link may (if it's the same problem) help resolve your issue.


https://brightrockgames.userecho.com/topics/1301-crash-when-loading-a-save-loading-certain-skirmish-maps-map-editor-maps-patch-142/


Can you let me know if that solves it or not (so I know if it's a new issue or not)

Going back to 1.4.1 did let me load the save file that was crashing. Thank you. I will have to find out now if it lets me finish the mission :)

Completed - Next Patch

It's the issue I was expecting then, in the mean time we've uploaded a patch 1.4.2f3 branch to the "publictest" beta branch which should also work as normal but will also include all of the bug fixes from patch 1.4.2


So you should be able to access that too, we'll be rolling that out as the main build soon once we're sure/confident that it's working as expected.


Marking as completed next patch but let us know if you have any more issues (particularly if you patch onto the publictest build and have any problems with it specifically)


Thanks