0
Completed - Resolved

wfto home realm crash when loading

MajHerbHead 3 years ago • updated by Lee "Noontide" Moon (Designer & Community Manager) 3 years ago 8

Hello

I'm having a problem loading my Home Realm in the main WftO campaign. I am on the 3rd time for trying now and thought it be time to bug report this problem. At this point in the game I know that I have dug the dungeon out ready for building and I don't even think it has any rooms yet either, may have 1 or 2, can't remember.

As it stands at the moment I am having to reset my home realm so I can listen to Mendechaus' ramblings so I can get the achievement. And I the fact I can't construct and keep a single home realm.


To note - If I RESET my home realm, it will let me load it up. But it will not let me reload it after exiting.


WftO Version 1.4.2f2


PC Specs


Operating System - Win10 64Bit

Motherboard - Asus P8Z77-LX2

CPU - Intel Core i5-3570K OC'd @ 4.1Ghz

Memory - 8Gb

GPU - Gainward GeForce 980GTX 8Gb


Save Files.zip

Outout Log.zip

Crash Report.zip

Game Version:
Steam Public
Platform:
Windows
Accepted

Sending this straight on to code. From what I can see there is indeed relevant info in the Output.log, looks like Mono (Unity?) is falling over.


Can you confirm the following for me?

  1. Did you start this home realm before the recent patch?
  2. Are you attempting to load a save or directly return to your home realm

Cheers,


Lee

Hi I'm having the exact same issue with the home realm with the Microsoft Visual C++ Runtime Library


Runtime Error!

Runtime Error! R6025
- pure virtual function call


Same error described in this thread

https://brightrockgames.userecho.com/topics/1135-save-game-crash/


Started with 1.4.2f2 patch with a home realm created before hand. I reset the home realm built up a large dungeon exit and tried to reload the hime dungeon and I am able to reproduce the Runtime error 100% of the time.



I too was getting this Runtime Error. Re-installed Visual C++ using redist's that came with WftO. Both x64 and x86. I no longer get the Runtime Error, its just the Home Realm wont load now.

Hi Lee


Thank you for your promptness with this.

1 - I did not no. I started a brand new game after the most recent patch.

2 - I am in the campaign screen where you choose what level you want to play. I go to the Home Realm from there.

If possible can you also check and run through the steps in here: General Crash Troubleshooting

That was actually one of the first things I did. After doing all that I repaired all Visual C++. And now, well you know the rest.

Hi MajHerbHead,


I'm curious about the fact that this may infact have been resolved by our changes in 1.4.2f5. Could you give the latest version of the game a try and let me know if you're still suffering from this issue?

Completed - Resolved

Marking as complete as we believe this should be resolved by our changes in Patch 1.4.2f5 and above.